mongo_database 1.0.0-dev.0

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mongo_database: ^1.0.0-dev.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mongo_database/mongo_database.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
30
Learn more about scoring.

We analyzed this package on Jul 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with runtime flutter-web on web

Because of the import of dart:io via the import chain package:mongo_database/mongo_database.dartpackage:mongo_database/src/db.dartpackage:mongo_database/src/collection.dartpackage:mongo_dart/mongo_dart.dartdart:io

Package not compatible with runtime web

Because of the import of dart:io via the import chain package:mongo_database/mongo_database.dartpackage:mongo_database/src/db.dartpackage:mongo_database/src/collection.dartpackage:mongo_dart/mongo_dart.dartdart:io

Maintenance issues and suggestions

Provide a file named README.md. (-30 points)

The README.md file should inform others about your project, what it does, and how they can use it. See the example generated by stagehand.

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://gitlab.com/rushio-consulting/mongo_database was unreachable.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (mongo_dart).

Package is getting outdated. (-74.52 points)

The package was last published 91 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and mongo_database.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution; their API can change in breaking ways.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
database_interface ^1.0.0-dev.0 1.0.0-dev.0
mongo_dart ^0.3.3 0.3.6 0.4.0
Transitive dependencies
async 2.4.2
bson 0.3.2
charcode 1.1.3
collection 1.14.13
conn_pool 2.1.9
convert 2.1.1
crypto 2.1.5
fixnum 0.10.11
logging 0.11.4
matcher 0.12.8
meta 1.2.1
mongo_dart_query 0.3.2 0.4.1
more 1.18.2 2.5.0
path 1.7.0
pool 1.4.0
quiver 2.1.3
stack_trace 1.9.5
typed_data 1.2.0
uuid 2.2.0
Dev dependencies
test ^1.0.0