mixin_bot_sdk_dart 0.2.3
mixin_bot_sdk_dart: ^0.2.3 copied to clipboard

Mixin Messenger API for Dart/Flutter, build decentrialized applications on Mixin

1
likes
110/ 130
pub points
47%
popularity

We analyzed this package on Dec 1, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 49 out of 1017 API elements (4.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.15.01.15.0
convert^3.0.13.0.13.0.1
crypto^3.0.13.0.13.0.1
dart_jsonwebtoken^2.3.22.4.02.4.0
dio^4.0.04.0.44.0.4
ed25519_edwards^0.2.10.2.10.3.1
enum_to_string^2.0.12.0.12.0.1
equatable^2.0.32.0.32.0.3
json_annotation^4.0.14.4.04.4.0
meta^1.4.01.7.01.7.0
recase^4.0.04.0.04.0.0
sprintf^6.0.06.0.06.0.0
uuid^3.0.43.0.53.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
http_parser-4.0.04.0.0
js-0.6.30.6.3
path-1.8.01.8.0
pointycastle-3.4.03.4.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.2.1` on ed25519_edwards does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions ed25519_edwards to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.