mapsforge_flutter 2.0.0
mapsforge_flutter: ^2.0.0 copied to clipboard

A port of mapsforge for pure flutter

7
likes
70/ 130
pub points
40%
popularity

We analyzed this package on Oct 25, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • dartdoc failed with:
exitCode: 255
stdout: [2021-10-27T12:48:18.122770] Starting...
Documenting mapsforge_flutter...
Initialized dartdoc with 1112 libraries in 126.3 seconds
Generating docs for library mapsforge_flutter from package:mapsforge_flutter/special.dart...
Generating docs for library mapsforge_flutter from package:mapsforge_flutter/marker.dart...
Generating docs for library mapsforge_flutter from package:mapsforge_flutter/maps.dart...
Generating docs for library mapsforge_flutter from package:mapsforge_flutter/datastore.dart...
Generating docs for library mapsforge_flutter from package:mapsforge_flutter/core.dart...
Documented 5 public libraries in 2.4 seconds

stderr:   warning: mapsforge_flutter has no library level documentation comments
    from mapsforge_flutter: (file:///tmp/pub-dartlang-dartdocFRXQEH/pkg/lib/special.dart:1:9)
  warning: mapsforge_flutter has no library level documentation comments
    from mapsforge_flutter: (file:///tmp/pub-dartlang-dartdocFRXQEH/pkg/lib/marker.dart:1:9)
  error: failed to write file at: mapsforge_flutter/mapsforge_flutter-library.html
    for symbol mapsforge_flutter: (file:///tmp/pub-dartlang-dartdocFRXQEH/pkg/lib/marker.dart:1:9)
    conflicting with file already generated by mapsforge_flutter: (file:///tmp/pub-dartlang-dartdocFRXQEH/pkg/lib/special.dart:1:9)
            Dartdoc generates a path and filename to write to for each symbol.
            mapsforge_flutter conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
  warning: unresolved doc reference [null]
    from mapsforge_flutter.BasicMarker.markerCaption: (file:///tmp/pub-dartlang-dartdocFRXQEH/pkg/lib/src/marker/basicmarker.dart:68:24)
    in documentation inherited from mapsforge_flutter.BasicMarker.markerCaption: (file:///tmp/pub-dartlang-dartdocFRXQEH/pkg/lib/src/marker/basicmarker.dart:68:24)
  warning: mapsforge_flutter has no library level documentation comments
    from mapsforge_flutter: (file:///tmp/pub-dartlang-dartdocFRXQEH/pkg/lib/maps.dart:1:9)
  error: failed to write file at: mapsforge_flutter/mapsforge_flutter-library.html
    for symbol mapsforge_flutter: (file:///tmp/pub-dartlang-dartdocFRXQEH/pkg/lib/maps.dart:1:9)
    conflicting with file already generated by mapsforge_flutter: (file:///tmp/pub-dartlang-dartdocFRXQEH/pkg/lib/marker.dart:1:9)
  warning: mapsforge_flutter has no library level documentation comments
    from mapsforge_flutter: (file:///tmp/pub-dartlang-dartdocFRXQEH/pkg/lib/datastore.dart:1:9)
  error: failed to write file at: mapsforge_flutter/mapsforge_flutter-library.html
    for symbol mapsforge_flutter: (file:///tmp/pub-dartlang-dartdocFRXQEH/pkg/lib/datastore.dart:1:9)
    conflicting with file already generated by mapsforge_flutter: (file:///tmp/pub-dartlang-dartdocFRXQEH/pkg/lib/maps.dart:1:9)
  warning: mapsforge_flutter has no library level documentation comments
    from mapsforge_flutter: (file:///tmp/pub-dartlang-dartdocFRXQEH/pkg/lib/core.dart:1:9)
  error: failed to write file at: mapsforge_flutter/mapsforge_flutter-library.html
    for symbol mapsforge_flutter: (file:///tmp/pub-dartlang-dartdocFRXQEH/pkg/lib/core.dart:1:9)
    conflicting with file already generated by mapsforge_flutter: (file:///tmp/pub-dartlang-dartdocFRXQEH/pkg/lib/datastore.dart:1:9)
Found 6 warnings and 4 errors.
Unhandled exception:
encountered 4 errors
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:241:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:33:19)
<asynchronous suspension>


Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:mapsforge_flutter/core.dart that imports:
  • package:mapsforge_flutter/src/cache/filetilebitmapcache.dart that imports:
  • package:mapsforge_flutter/src/utils/filehelper.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 113 issues. Showing the first 2:

lib/src/cache/filesymbolcache.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/cache/filetilebitmapcache.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.0-nullsafety.41.15.01.15.0
convert^3.0.03.0.13.0.1
ecache^2.0.12.0.12.0.1
flutterflutter0.0.00.0.0
flutter_svg^0.22.00.22.00.23.0+1
http^0.13.30.13.40.13.4
logging^1.0.11.0.21.0.2
path_provider^2.0.12.0.52.0.5
provider^5.0.05.0.06.0.1
rxdart^0.27.00.27.20.27.2
synchronized^3.0.03.0.03.0.0
xml^5.1.05.3.15.3.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
ffi-1.1.21.1.2
file-6.1.26.1.2
http_parser-4.0.04.0.0
meta-1.7.01.7.0
nested-1.0.01.0.0
path-1.8.01.8.0
path_drawing-0.5.1+10.5.1+1
path_parsing-0.2.10.2.1
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
petitparser-4.4.04.4.0
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.2.102.2.10
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.22.0` on flutter_svg does not support the stable version `0.23.0`, that was published 12 days ago.

When flutter_svg is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_svg to update the constraint.

The constraint `^5.0.0` on provider does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.