m4d_router 0.2.18
m4d_router: ^0.2.18 copied to clipboard

A browser routing library for Dart

0
likes
50 / 130
pub points
50 %
popularity

We analyzed this package on May 4, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:13:10

   ╷
13 │ <p>Live: <a href="http://m4d_router.example.mikemitterer.at/">m4d_router.example.mikemitterer.at</a><br />
   │          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 2 links are insecure.

CHANGELOG.md:3:5

  ╷
3 │ <h2><a href="http://github.com/mikemitterer/m4d_router/compare/v0.2...HEAD">Unreleased</a></h2>
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 56 API elements (37.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:m4d_router/browser.dart that imports:
  • dart:html
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 51 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/browser.dart:25:17

   ╷
25 │ final _logger = new Logger('m4d_router.browser');
   │                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/browser.dart

INFO: Unnecessary new keyword.

lib/browser.dart:40:21

   ╷
40 │     final _logger = new Logger('m4d_router.browser.router');
   │                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/browser.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
logging>=0.11.3 <1.0.00.11.41.0.1
uri^0.11.00.11.41.0.0
validate^1.0.01.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
matcher-0.12.100.12.10
meta-1.3.01.3.0
quiver-2.1.53.0.1
stack_trace-1.10.01.10.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.11.3 <1.0.0` on logging does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions logging to update the constraint.

The constraint `^0.11.0` on uri does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions uri to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

0
likes
50
pub points
50%
popularity

A browser routing library for Dart

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

office@mikemitterer.at

License

Apache 2.0 (LICENSE)

Dependencies

logging, uri, validate

More

Packages that depend on m4d_router