m4d_router 0.2.18

Dart js
Flutter web

A browser routing library for Dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  m4d_router: ^0.2.18

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:m4d_router/browser.dart';
import 'package:m4d_router/exceptions.dart';
import 'package:m4d_router/exeptions/RouteNotFoundException.dart';
import 'package:m4d_router/route.dart';
import 'package:m4d_router/router.dart';
import 'package:m4d_router/url_pattern.dart';
import 'package:m4d_router/utils/async_utils.dart';
import 'package:m4d_router/utils/map_utils.dart';
0
likes
60
pub points
54%
popularity

A browser routing library for Dart

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

office@mikemitterer.at

License

Apache 2.0 (LICENSE)

Dependencies

logging, uri, validate

More

Packages that depend on m4d_router