m4d 0.1.0

Dart js

Material 4 Dart - Meta-Package

0
likes
70 / 110
pub points
6 %
popularity

We analyzed this package on Aug 7, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 1 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:m4d/m4d.dart that imports:
  • package:m4d_translate/m4d_translate.dart that imports:
  • package:m4d_core/m4d_core.dart that imports:
  • dart:js
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/m4d.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
m4d_animation>=0.1.0 <1.0.00.1.40.1.4
m4d_components>=0.1.0 <1.0.00.1.310.1.31
m4d_core>=0.1.0 <1.0.00.2.210.2.21
m4d_dialog>=0.1.0 <1.0.00.2.30.2.3
m4d_directive>=0.1.0 <1.0.00.1.160.1.16
m4d_dnd>=0.1.0 <1.0.00.1.70.1.7
m4d_flux>=0.1.0 <1.0.00.1.00.1.0
m4d_form>=0.1.0 <1.0.00.1.60.1.6
m4d_router>=0.1.0 <1.0.00.2.180.2.18
m4d_spa>=0.1.0 <1.0.00.1.120.1.12
m4d_template>=0.1.0 <1.0.00.2.90.2.9
m4d_translate>=0.1.0 <1.0.00.1.60.1.6
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-6.0.06.0.0
analyzer-0.39.160.39.16
ansicolor-1.0.21.0.2
args-1.6.01.6.0
async-2.4.22.4.2
build_cli_annotations-1.2.01.2.0
charcode-1.1.31.1.3
cli_util-0.1.40.2.0
collection-1.14.131.14.13
console_log_handler-1.1.61.1.6
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart_style-1.3.61.3.6
dnd-1.4.31.4.3
glob-1.2.01.2.0
html-0.14.0+30.14.0+3
intl-0.15.80.16.1
intl_translation-0.17.100.17.10
js-0.6.20.6.2
l10n-2.0.192.0.19
logging-0.11.40.11.4
matcher-0.12.90.12.9
meta-1.2.21.2.2
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
optional-3.1.05.0.0
package_config-1.9.31.9.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
petitparser-3.1.03.1.0
platform_detect-1.4.01.4.0
pub_semver-1.4.41.4.4
quiver-2.1.32.1.3
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
uri-0.11.3+10.11.3+1
utf-0.9.0+50.9.0+5
validate-1.7.01.7.0
watcher-0.9.7+150.9.7+15
where-4.4.08.0.0
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs