m4d_dialog 0.2.3

  • Readme
  • Changelog
  • Installing
  • 25

Material 4 Dart - Dialogs #

Examples #

GitHub

Change Log for m4d_dialog #

Material Design 4 Dart - Dialogs

Unreleased #

Refactor #

  • Fighting against Darts broken dependency-management-system c3cf4ad

v0.1 - 2018-11-14 #

Docs #

  • All examples are working 4a0b184
  • Basic-Dialogs like AlertDialog, ConfirmDialog are working 272c81e
  • Removed wrong examples from README 89f0e27

This CHANGELOG.md was generated with Changelog for Dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  m4d_dialog: ^0.2.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:m4d_dialog/m4d_dialog.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
75
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
13
Overall:
Weighted score of the above. [more]
25
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with SDK flutter

Because it is not compatible with any of the supported runtimes: flutter-native, flutter-web

Package not compatible with runtime flutter-native on android

Because of the import of dart:js via the import chain package:m4d_dialog/m4d_dialog.dartpackage:m4d_translate/m4d_translate.dartpackage:m4d_core/m4d_core.dartdart:js

Package not compatible with runtime flutter-native on ios

Because of the import of dart:js via the import chain package:m4d_dialog/m4d_dialog.dartpackage:m4d_translate/m4d_translate.dartpackage:m4d_core/m4d_core.dartdart:js

Package not compatible with runtime flutter-native on linux

Because of the import of dart:js via the import chain package:m4d_dialog/m4d_dialog.dartpackage:m4d_translate/m4d_translate.dartpackage:m4d_core/m4d_core.dartdart:js

Package not compatible with runtime flutter-native on macos

Because of the import of dart:js via the import chain package:m4d_dialog/m4d_dialog.dartpackage:m4d_translate/m4d_translate.dartpackage:m4d_core/m4d_core.dartdart:js

Package not compatible with runtime flutter-native on windows

Because of the import of dart:js via the import chain package:m4d_dialog/m4d_dialog.dartpackage:m4d_translate/m4d_translate.dartpackage:m4d_core/m4d_core.dartdart:js

Package not compatible with runtime flutter-web on web

Because of the import of dart:html_common via the import chain package:m4d_dialog/m4d_dialog.dartpackage:m4d_animation/m4d_animation.dartdart:html_common

Package not compatible with runtime native-aot

Because of the import of dart:js via the import chain package:m4d_dialog/m4d_dialog.dartpackage:m4d_translate/m4d_translate.dartpackage:m4d_core/m4d_core.dartdart:js

Package not compatible with runtime native-jit

Because of the import of dart:js via the import chain package:m4d_dialog/m4d_dialog.dartpackage:m4d_translate/m4d_translate.dartpackage:m4d_core/m4d_core.dartdart:js

Health suggestions

Fix lib/dialog/MaterialDatePicker.dart. (-13.96 points)

Analysis of lib/dialog/MaterialDatePicker.dart reported 30 hints, including:

line 24 col 35: Unnecessary new keyword.

line 27 col 25: Unnecessary new keyword.

line 30 col 20: Unnecessary new keyword.

line 33 col 18: Unnecessary new keyword.

line 36 col 34: Unnecessary new keyword.

Fix lib/dialog/MaterialDialog.dart. (-12.22 points)

Analysis of lib/dialog/MaterialDialog.dart reported 26 hints, including:

line 38 col 1: Prefer using /// for doc comments.

line 56 col 52: Unnecessary new keyword.

line 74 col 50: Use = to separate a named parameter from its default value.

line 75 col 51: Use = to separate a named parameter from its default value.

line 76 col 47: Use = to separate a named parameter from its default value.

Fix lib/dialog/MaterialTimePicker.dart. (-5.84 points)

Analysis of lib/dialog/MaterialTimePicker.dart reported 12 hints, including:

line 24 col 35: Unnecessary new keyword.

line 27 col 25: Unnecessary new keyword.

line 30 col 20: Unnecessary new keyword.

line 33 col 22: Unnecessary new keyword.

line 35 col 34: Unnecessary new keyword.

Fix additional 6 files with analysis or formatting issues. (-16.25 points)

Additional issues in the following files:

  • lib/dialog/MaterialNotification.dart (10 hints)
  • lib/dialog/MaterialSnackbar.dart (7 hints)
  • lib/dialog/MaterialConfirmDialog.dart (6 hints)
  • lib/dialog/components/MaterialDialogComponent.dart (6 hints)
  • lib/dialog/MaterialAlertDialog.dart (4 hints)
  • lib/m4d_dialog.dart (Run dartfmt to format lib/m4d_dialog.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (intl).

Package is getting outdated. (-47.12 points)

The package was last published 76 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and m4d_dialog.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
console_log_handler ^1.0.0 1.1.6
intl ^0.15.0 0.15.8 0.16.1
logging >=0.11.3 <1.0.0 0.11.4
m4d_animation >=0.1.0 <1.0.0 0.1.4
m4d_components >=0.1.0 <1.0.0 0.1.31
m4d_core >=0.2.0 <1.0.0 0.2.21
m4d_flux >=0.1.0 <1.0.0 0.1.0
m4d_template >=0.1.0 <1.0.0 0.2.9
m4d_translate >=0.1.0 <1.0.0 0.1.6
meta ^1.1.0 1.2.1
path ^1.4.0 1.7.0
platform_detect ^1.3.0 1.4.0
validate ^1.0.0 1.7.0
Transitive dependencies
_fe_analyzer_shared 5.0.0
analyzer 0.39.12
ansicolor 1.0.2
args 1.6.0
async 2.4.2
build_cli_annotations 1.2.0
charcode 1.1.3
collection 1.14.13
convert 2.1.1
crypto 2.1.5
csslib 0.16.1
dart_style 1.3.6
glob 1.2.0
html 0.14.0+3
intl_translation 0.17.10
js 0.6.2
l10n 2.0.19
m4d_directive 0.1.16
node_interop 1.1.1
node_io 1.1.1
optional 3.1.0 5.0.0
package_config 1.9.3
pedantic 1.9.1
petitparser 3.0.4
pub_semver 1.4.4
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0
watcher 0.9.7+15
where 4.4.0 8.0.0
yaml 2.2.1
Dev dependencies
build_runner any
build_test any
build_web_compilers any
test any