m4d 0.1.0

Material 4 Dart - Meta-Package #

1.0.0 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  m4d: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:m4d/m4d.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Jul 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: web

Primary library: package:m4d/m4d.dart with components: html, js.

Health suggestions

Format lib/m4d.dart.

Run dartfmt to format lib/m4d.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and m4d.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
m4d_animation >=0.1.0 <1.0.0 0.1.4
m4d_components >=0.1.0 <1.0.0 0.1.31
m4d_core >=0.1.0 <1.0.0 0.2.21
m4d_dialog >=0.1.0 <1.0.0 0.2.3
m4d_directive >=0.1.0 <1.0.0 0.1.16
m4d_dnd >=0.1.0 <1.0.0 0.1.7
m4d_flux >=0.1.0 <1.0.0 0.1.0
m4d_form >=0.1.0 <1.0.0 0.1.6
m4d_router >=0.1.0 <1.0.0 0.2.18
m4d_spa >=0.1.0 <1.0.0 0.1.12
m4d_template >=0.1.0 <1.0.0 0.2.9
m4d_translate >=0.1.0 <1.0.0 0.1.6
Transitive dependencies
analyzer 0.36.4 0.37.0
ansicolor 1.0.2
args 1.5.2
async 2.2.0
build_cli_annotations 1.1.0
charcode 1.1.2
collection 1.14.11
console_log_handler 1.1.6
convert 2.1.1
crypto 2.0.6
csslib 0.16.1
dart_style 1.2.9
dnd 1.4.2
front_end 0.1.19 0.1.20
glob 1.1.7
html 0.14.0+2
intl 0.15.8
intl_translation 0.17.5
kernel 0.3.19 0.3.20
l10n 2.0.19
logging 0.11.3+2
matcher 0.12.5
meta 1.1.7
optional 3.0.2+1
package_config 1.0.5
path 1.6.2
pedantic 1.8.0+1
petitparser 2.4.0
platform_detect 1.3.5
pub_semver 1.4.2
quiver 2.0.3
source_span 1.5.5
stack_trace 1.9.3
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
uri 0.11.3+1
utf 0.9.0+5
validate 1.7.0
watcher 0.9.7+12
where 4.4.0 6.3.0
yaml 2.1.16
Dev dependencies
build_runner any
build_web_compilers any
sass_builder any
test ^1.0.0

Admin