m4d_translate 0.1.6

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 43

Material 4 Dart - Translate-Component #

Examples #

GitHub

Change Log for m4d_translate #

Material Design 4 Dart - Translate

Unreleased #

Bugs #

  • Wrong description in HTML-Template 4526e59

Docs #

This CHANGELOG.md was generated with Changelog for Dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  m4d_translate: ^0.1.6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:m4d_translate/m4d_translate.dart';
  
Version Uploaded Documentation Archive
0.1.6 Dec 19, 2018 Go to the documentation of m4d_translate 0.1.6 Download m4d_translate 0.1.6 archive
0.1.1 Nov 13, 2018 Go to the documentation of m4d_translate 0.1.1 Download m4d_translate 0.1.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
65
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Jun 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18

Platforms

Detected platforms: web

Primary library: package:m4d_translate/m4d_translate.dart with components: html, js.

Health suggestions

Fix lib/translate/MaterialTranslate.dart. (-0.50 points)

Analysis of lib/translate/MaterialTranslate.dart reported 1 hint:

line 57 col 5: Avoid return types on setters.

Format lib/m4d_translate.dart.

Run dartfmt to format lib/m4d_translate.dart.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and m4d_translate.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
console_log_handler ^1.0.0 1.1.6
l10n >=2.0.0 <3.0.0 2.0.19
logging >=0.11.3 <1.0.0 0.11.3+2
m4d_core >=0.2.0 <1.0.0 0.2.21
validate ^1.0.0 1.7.0
Transitive dependencies
analyzer 0.36.3
ansicolor 1.0.2
args 1.5.2
async 2.2.0
build_cli_annotations 1.1.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
csslib 0.16.0
dart_style 1.2.8
front_end 0.1.18
glob 1.1.7
html 0.14.0+2
intl 0.15.8
intl_translation 0.17.5
kernel 0.3.18
meta 1.1.7
optional 3.0.2+1
package_config 1.0.5
path 1.6.2
petitparser 2.3.0
platform_detect 1.3.5
pub_semver 1.4.2
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+10
where 4.4.0 6.3.0
yaml 2.1.16
Dev dependencies
build_runner any
build_test any
build_web_compilers any
test any