localize_and_translate 3.0.1

Flutter Android iOS

Flutter localization in easy steps, simple ways to localize and translate your app

36
likes
100 / 110
pub points
83 %
popularity

We analyzed this package on Aug 5, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 31 API elements (48.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:localize_and_translate/localize_and_translate.dart that imports:
  • package:localize_and_translate/src/main.class.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_linux/shared_preferences_linux.dart that declares support for platforms: Linux

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:localize_and_translate/localize_and_translate.dart that imports:
  • package:localize_and_translate/src/main.class.dart that imports:
  • package:shared_preferences/shared_preferences.dart that declares support for platforms: Android, iOS, Linux, macOS, Web
Package does not support Flutter platform Linux

Because:

  • package:localize_and_translate/localize_and_translate.dart that imports:
  • package:localize_and_translate/src/main.class.dart that imports:
  • package:devicelocale/devicelocale.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:localize_and_translate/localize_and_translate.dart that imports:
  • package:localize_and_translate/src/main.class.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_linux/shared_preferences_linux.dart that declares support for platforms: Linux

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:localize_and_translate/localize_and_translate.dart that imports:
  • package:localize_and_translate/src/main.class.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_linux/shared_preferences_linux.dart that declares support for platforms: Linux
Package does not support Flutter platform iOS

Because:

  • package:localize_and_translate/localize_and_translate.dart that imports:
  • package:localize_and_translate/src/main.class.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_linux/shared_preferences_linux.dart that declares support for platforms: Linux
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
devicelocale^0.3.10.3.10.3.1
flutterflutter0.0.00.0.0
flutter_localizationsflutter0.0.00.0.0
http^0.12.20.12.20.12.2
intl^0.16.00.16.10.16.1
shared_preferences^0.5.80.5.80.5.8
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.121.14.13
file-5.2.15.2.1
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.43.1.4
meta-1.1.81.2.2
path-1.6.41.7.0
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.21.0.2
pedantic-1.9.01.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.21.0.2
process-3.0.133.0.13
shared_preferences_linux-0.0.2+10.0.2+1
shared_preferences_macos-0.0.1+100.0.1+10
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.1.61.2.0
vector_math-2.0.82.0.8
xdg_directories-0.1.00.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

36
likes
100
pub points
83%
popularity

Publisher

msayed.net

Flutter localization in easy steps, simple ways to localize and translate your app

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

devicelocale, flutter, flutter_localizations, http, intl, shared_preferences

More

Packages that depend on localize_and_translate