koin_devtools 0.2.2
koin_devtools: ^0.2.2 copied to clipboard

DevTools to inspect the state of Koin.dart scope instances.

3
likes
80/ 130
pub points
59%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 5 API elements (60.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
expandable^4.1.44.1.45.0.1
flutterflutter0.0.00.0.0
koin^0.14.20.14.20.14.2
koin_flutter^0.10.00.10.00.10.0
kt_dart^0.8.00.8.00.9.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.1.4` on expandable does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions expandable to update the constraint.

The constraint `^0.8.0` on kt_dart does not support the stable version `0.9.0`.

Try running dart pub upgrade --major-versions kt_dart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

3
likes
80
pub points
59%
popularity

DevTools to inspect the state of Koin.dart scope instances.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

expandable, flutter, koin, koin_flutter, kt_dart

More

Packages that depend on koin_devtools