koin_flutter 0.3.0

koin_flutter #

Build Status codecov

A package to make it easier to use Koin.darton the Flutter.

Warning #

Koin.dart port does not have all the koin features implemented yet, and what it already has is not fully tested. I do not recommend using it yet.

0.3.0 #

  • Added BlocExtension
  • Minor improvements
  • Change to Koin 0.3.2
  • ScopeComponent renamed to ScopeComponentMixin

0.2.0 #

  • Added ScopeComponent
  • Minor improvements

0.1.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  koin_flutter: ^0.3.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:koin_flutter/koin_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
24
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
58
Learn more about scoring.

We analyzed this package on Feb 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health suggestions

Format lib/koin_flutter.dart.

Run flutter format to format lib/koin_flutter.dart.

Format lib/scope_provider.dart.

Run flutter format to format lib/scope_provider.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (provider).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and koin_flutter.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
koin ^0.3.2 0.3.2+3
provider ^3.2.0 3.2.0 4.0.4
Transitive dependencies
collection 1.14.11 1.14.12
equatable 1.1.0
kt_dart 0.6.2 0.7.0-dev.4
meta 1.1.8
path 1.6.4
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test