kkiapay_flutter_sdk 1.3.1 copy "kkiapay_flutter_sdk: ^1.3.1" to clipboard
kkiapay_flutter_sdk: ^1.3.1 copied to clipboard

KKiaPay allows businesses to safely receive payments by mobile money, credit card and bank account.

26
likes
150/ 160
pub points
84%
popularity

We analyzed this package 2 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

37 out of 94 API elements (39.4 %) have documentation comments.

Some symbols that are missing documentation: kkiapay_flutter_sdk, kkiapay_flutter_sdk.CLOSE_WIDGET, kkiapay_flutter_sdk.DESTROY_WIDGET, kkiapay_flutter_sdk.INIT_WIDGET, kkiapay_flutter_sdk.KKiaPay.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:kkiapay_flutter_sdk/kkiapay_flutter_sdk.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:kkiapay_flutter_sdk/kkiapay_flutter_sdk.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:kkiapay_flutter_sdk/kkiapay_flutter_sdk.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:kkiapay_flutter_sdk/kkiapay_flutter_sdk.dart that imports:
  • package:kkiapay_flutter_sdk/src/features/mobile/kkiapay.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:kkiapay_flutter_sdk/kkiapay_flutter_sdk.dart that imports:
  • package:kkiapay_flutter_sdk/src/features/mobile/kkiapay.dart that imports:
  • package:webview_flutter_android/webview_flutter_android.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:kkiapay_flutter_sdk/kkiapay_flutter_sdk.dart that imports:
  • package:kkiapay_flutter_sdk/src/features/mobile/kkiapay.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 23 issues. Showing the first 2:

INFO: The import of 'kkiapay_flutter_sdk_platform_interface.dart' is unnecessary because all of the used elements are also provided by the import of 'kkiapay_flutter_sdk.dart'.

lib/kkiapay_flutter_sdk_web.dart:10:8

   ╷
10 │ import 'kkiapay_flutter_sdk_platform_interface.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/kkiapay_flutter_sdk_web.dart

INFO: An uninitialized field should have an explicit type annotation.

lib/src/utils/config.dart:81:9

   ╷
81 │   final reason, name, email, sandbox, phone, data, apikey, theme, paymentMethod, callbackUrl, countries,partnerId;
   │         ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/utils/config.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cupertino_icons ^1.0.6 1.0.8 1.0.8
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
http ^1.2.1 1.2.1 1.2.1
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
stacked ^3.4.2 3.4.3 3.4.3
stacked_services ^1.5.0 1.5.0 1.5.0
stacked_shared ^1.4.0 1.4.1 1.4.1
url_launcher ^6.2.1 6.3.0 6.3.0
web ^0.5.1 0.5.1 0.5.1
webview_flutter ^4.7.0 4.8.0 4.8.0
webview_flutter_android ^3.16.0 3.16.4 3.16.4
webview_flutter_wkwebview ^3.13.0 3.14.0 3.14.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
crypto - 3.0.3 3.0.3
get - 4.6.6 4.6.6
get_it - 7.7.0 7.7.0
http_parser - 4.0.2 4.1.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
path - 1.9.0 1.9.0
provider - 6.1.2 6.1.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
universal_io - 2.2.2 2.2.2
url_launcher_android - 6.3.3 6.3.3
url_launcher_ios - 6.3.1 6.3.1
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
webview_flutter_platform_interface - 2.10.0 2.10.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

26
likes
150
pub points
84%
popularity

Publisher

unverified uploader

KKiaPay allows businesses to safely receive payments by mobile money, credit card and bank account.

Homepage

Documentation

API reference

License

MIT (license)

Dependencies

cupertino_icons, flutter, flutter_web_plugins, http, plugin_platform_interface, stacked, stacked_services, stacked_shared, url_launcher, web, webview_flutter, webview_flutter_android, webview_flutter_wkwebview

More

Packages that depend on kkiapay_flutter_sdk