kd_cli 0.0.1 copy "kd_cli: ^0.0.1" to clipboard
kd_cli: ^0.0.1 copied to clipboard

This is a CLI to process the test and coverage report.

1
likes
70/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 70 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected licenses: BSD-3-Clause, MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1 out of 1 API elements (100.0 %) have documentation comments.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:kd_cli/src/commands/packages/packages_command.dart'.

lib/src/kd_command_runner.dart:3:8

  ╷
3 │ import 'package:kd_cli/src/commands/packages/packages_command.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/kd_command_runner.dart

ERROR: The method 'PackagesCommand' isn't defined for the type 'KdCommandRunner'.

lib/src/kd_command_runner.dart:21:16

   ╷
21 │     addCommand(PackagesCommand());
   │                ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/kd_command_runner.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.3.2 2.5.0 2.5.0
async ^2.10.0 2.11.0 2.11.0
checked_yaml ^2.0.2 2.0.3 2.0.3
glob ^2.1.1 2.1.2 2.1.2
lcov_dart ^7.0.0 7.0.0 7.0.0
mason_logger ^0.2.5 0.2.12 0.2.12
path ^1.8.3 1.9.0 1.9.0
pool ^1.5.1 1.5.1 1.5.1
pubspec ^2.3.0 2.3.0 2.3.0
universal_io ^2.0.4 2.2.2 2.2.2
Transitive dependencies
Package Constraint Compatible Latest
boolean_selector - 2.1.1 2.1.1
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
io - 1.0.4 1.0.4
json_annotation - 4.8.1 4.8.1
matcher - 0.12.16+1 0.12.16+1
meta - 1.14.0 1.14.0
pub_semver - 2.1.4 2.1.4
quiver - 3.2.1 3.2.1
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.1 0.7.1
typed_data - 1.3.2 1.3.2
uri - 1.0.0 1.0.0
win32 - 5.4.0 5.4.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

1
likes
70
pub points
0%
popularity

Publisher

verified publisherunicodelabs.in

This is a CLI to process the test and coverage report.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause, MIT (LICENSE)

Dependencies

args, async, checked_yaml, glob, lcov_dart, mason_logger, path, pool, pubspec, universal_io

More

Packages that depend on kd_cli