katex_flutter 4.0.2+26 copy "katex_flutter: ^4.0.2+26" to clipboard
katex_flutter: ^4.0.2+26 copied to clipboard

Performantly render scientific LaTeX equations using the KaTeX library on Android, iOS, the Web and the Desktop platform.

54
likes
40/ 140
pub points
74%
popularity

We analyzed this package 9 hours ago, and awarded it 40 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: EUPL-1.2.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
The lower bound of "sdk: '>=2.8.1 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.4.0-131.0.dev. Cannot run `flutter pub outdated`.

pubspec.yaml:9:8

  ╷
9 │   sdk: ">=2.8.1 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.4.0-131.0.dev.

pubspec.yaml:9:8

  ╷
9 │   sdk: ">=2.8.1 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.4.0-99.0.dev)

pubspec.yaml:9:8

  ╷
9 │   sdk: ">=2.8.1 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Analyzed with Pana 0.22.1, Flutter 3.20.0-1.1.pre, Dart 3.4.0-99.0.dev.

Check the analysis log for details.

54
likes
40
pub points
74%
popularity

Publisher

verified publishertestapp.schule

Performantly render scientific LaTeX equations using the KaTeX library on Android, iOS, the Web and the Desktop platform.

Repository (GitLab)
View/report issues

License

EUPL-1.2 (LICENSE)

Dependencies

catex, flutter

More

Packages that depend on katex_flutter