karyo 0.0.1
karyo: ^0.0.1 copied to clipboard

Essential lib of all apps in MANA orgnization.

0
likes
50/ 130
pub points
0%
popularity

We analyzed this package on Nov 28, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 137 API elements (1.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:karyo/karyo.dart that imports:
  • package:karyo/src/app_utils.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

lib/src/app_utils.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/color_utils.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
animations^1.1.21.1.22.0.2
audioplayers^0.16.20.16.20.20.1
cached_network_image^2.5.02.5.13.1.0+1
charts_flutter^0.9.00.9.00.12.0
community_material_icon^5.3.455.9.555.9.55
cupertino_icons^1.0.11.0.41.0.4
flutterflutter0.0.00.0.0
flutter_custom_dialog^1.0.201.2.01.2.0
flutter_displaymode^0.1.10.1.10.3.2
flutter_launcher_icons^0.8.10.8.10.9.2
flutter_local_notifications^3.0.1+23.0.39.1.4
flutter_native_timezone^1.0.41.1.02.0.0
flutter_speed_dial^1.2.51.2.54.6.6
flutter_svg^0.18.00.18.10.23.0+1
fluttertoast^7.1.67.1.88.0.8
fluwx^2.3.02.6.23.6.1+4
image_gallery_saver^1.5.01.7.11.7.1
meta^1.2.41.7.01.7.0
modal_bottom_sheet^1.0.01.0.0+12.0.0
package_info^0.4.30.4.3+42.0.2
path_provider^1.6.71.6.282.0.7
random_color^1.0.51.0.51.0.5
rxdart^0.24.00.24.10.27.3
shared_preferences^0.5.12+40.5.12+42.0.9
timezone^0.5.90.5.90.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.6
args-1.6.02.3.0
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
charts_common-0.9.00.12.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_blurhash-0.5.00.6.0
flutter_cache_manager-2.1.23.2.0
flutter_local_notifications_platform_interface-2.0.0+15.0.0
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
image-2.1.193.0.8
intl-0.16.10.17.0
js-0.6.30.6.3
logging-1.0.21.0.2
octo_image-0.3.01.0.0+1
path-1.8.01.8.0
path_drawing-0.4.1+10.5.1+1
path_parsing-0.1.40.2.1
path_provider_linux-0.0.1+22.1.2
path_provider_macos-0.0.4+82.0.3
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.4
pedantic-1.11.11.11.1
petitparser-3.1.04.4.0
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
shared_preferences_linux-0.0.2+42.0.3
shared_preferences_macos-0.0.1+112.0.2
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.2
shared_preferences_windows-0.0.2+32.0.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.0+42.0.0+4
sqflite_common-2.0.1+12.0.1+1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.5
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.1.20.2.0
xml-4.5.15.3.1
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 18 issues. Showing the first 2:

The constraint `^1.1.2` on animations does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions animations to update the constraint.

The constraint `^0.16.2` on audioplayers does not support the stable version `0.17.0`.

Try running dart pub upgrade --major-versions audioplayers to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.