jiosaavn_wrapper 0.0.2+18 copy "jiosaavn_wrapper: ^0.0.2+18" to clipboard
jiosaavn_wrapper: ^0.0.2+18 copied to clipboard

A wrapper for unofficial jio_saavn api.

5
likes
90/ 140
pub points
8%
popularity

We analyzed this package 6 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Repository URL doesn't exist.

At the time of the analysis https://github.com/teamDrt280320/jiosaavn_wrapper was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: jiosaavn_wrapper,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

4 out of 239 API elements (1.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: artist, artist.Artist, artist.Artist.Artist, artist.Artist.copyWith, artist.Artist.id.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:jiosaavn_wrapper/jiosaavn_wrapper.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:jiosaavn_wrapper/jiosaavn_wrapper.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:jiosaavn_wrapper/jiosaavn_wrapper.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:jiosaavn_wrapper/jiosaavn_wrapper.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

WARNING: Unused import: 'package:jiosaavn_wrapper/modals/search_result.dart'.

lib/modals/song.dart:3:8

  ╷
3 │ import 'package:jiosaavn_wrapper/modals/search_result.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/modals/song.dart

INFO: The import of 'package:jiosaavn_wrapper/utilities/extensions.dart' is unnecessary because all of the used elements are also provided by the import of 'package:jiosaavn_wrapper/jiosaavn_wrapper.dart'.

lib/factories/song_factory.dart:11:8

   ╷
11 │ import 'package:jiosaavn_wrapper/utilities/extensions.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/factories/song_factory.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dart_des ^1.0.0 1.0.2 1.0.2
flutter flutter 0.0.0 0.0.0
flutter_cache ^0.1.0 0.1.0 0.1.0
http ^0.13.3 0.13.6 1.2.1
intl ^0.17.0 0.17.0 0.19.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences - 2.2.3 2.2.3
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.3` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.