ivybaby_api 0.1.2 icon indicating copy to clipboard operation
ivybaby_api: ^0.1.2 copied to clipboard

A new Flutter plugin.

0
likes
55/ 140
pub points
0%
popularity

We analyzed this package 3 hours ago, and awarded it 55 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
15 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No CHANGELOG.md found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 200 API elements (5.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:ivybaby_api/annotation/api_extension_generator.dart that imports:
  • package:ivybaby_api/annotation/api_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors

Package not compatible with platform iOS

Because:

  • package:ivybaby_api/annotation/api_extension_generator.dart that imports:
  • package:ivybaby_api/annotation/api_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors

Package not compatible with platform Windows

Because:

  • package:ivybaby_api/annotation/api_extension_generator.dart that imports:
  • package:ivybaby_api/annotation/api_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors

Package not compatible with platform Linux

Because:

  • package:ivybaby_api/annotation/api_extension_generator.dart that imports:
  • package:ivybaby_api/annotation/api_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors

Package not compatible with platform macOS

Because:

  • package:ivybaby_api/annotation/api_extension_generator.dart that imports:
  • package:ivybaby_api/annotation/api_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors

Package not compatible with platform Web

Because:

  • package:ivybaby_api/annotation/annotation_util.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/util/comment.dart that imports:
  • package:analyzer/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/generated/parser.dart that imports:
  • package:analyzer/src/dart/ast/utilities.dart that imports:
  • package:analyzer/src/dart/ast/constant_evaluator.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/dart/resolver/scope.dart that imports:
  • package:analyzer/src/dart/element/scope.dart that imports:
  • package:analyzer/src/context/source.dart that imports:
  • package:analyzer/src/workspace/package_build.dart that imports:
  • package:analyzer/src/workspace/workspace.dart that imports:
  • package:analyzer/src/workspace/bazel.dart that imports:
  • package:analyzer/src/summary/package_bundle_reader.dart that imports:
  • package:analyzer/src/generated/source_io.dart that imports:
  • package:analyzer/src/generated/java_io.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 21 issues. Showing the first 2:

INFO: 'List.List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/annotation/api_generator.dart:117:22

    ╷
117 │         urlImports = List<Map<String, dynamic>>();
    │                      ^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/annotation/api_generator.dart

INFO: 'List.List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/annotation/api_generator.dart:258:17

    ╷
258 │         funcs = List<Map<String, dynamic>>();
    │                 ^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/annotation/api_generator.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.40.60.40.75.2.0
build^1.6.01.6.22.3.1
convert^2.1.12.1.13.1.1
crypto^2.0.62.1.53.0.2
cupertino_icons^1.0.01.0.51.0.5
dio^3.0.93.0.104.0.6
flutterflutter0.0.00.0.0
json_annotation^3.1.13.1.14.7.0
mustache^1.1.11.1.11.1.1
source_gen^0.9.80.9.10+21.2.6
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.050.0.0
args-1.6.02.3.1
async-2.10.02.10.0
characters-1.2.11.2.1
charcode-1.3.11.3.1
cli_util-0.2.00.3.5
clock-1.1.11.1.1
collection-1.16.01.17.0
dart_style-1.3.102.2.4
file-5.2.16.1.4
glob-1.2.12.1.1
http_parser-3.1.44.0.2
intl-0.17.00.17.0
js-0.6.50.6.5
logging-1.1.01.1.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
node_interop-1.2.12.1.0
node_io-1.2.02.2.0
package_config-1.9.32.1.0
path-1.8.21.8.2
pedantic-1.11.11.11.1
pub_semver-1.4.42.1.3
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.4
watcher-0.9.7+151.0.2
yaml-2.2.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint ^0.40.6 on analyzer does not support the stable version 0.41.0.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint ^1.6.0 on build does not support the stable version 2.0.0.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.7.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.