iran_appmarket 0.4.1
iran_appmarket: ^0.4.1 copied to clipboard

A Flutter plugin to open the apps page in an iranian android market.

2
likes
70 / 130
pub points
31 %
popularity

We analyzed this package on Jun 22, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 18 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform iOS

Because:

  • package:iran_appmarket/iran_appmarket.dart that imports:
  • package:iran_appmarket/src/app_market.dart that imports:
  • package:iran_appmarket/src/jhoobin.dart that imports:
  • package:android_intent/android_intent.dart that declares support for platforms: Android
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

lib/src/app_market.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/bazaar.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
android_intentany2.0.22.0.2
flutterflutter0.0.00.0.0
get_versionany0.2.20.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.4.0
package_info-0.4.3+42.0.2
platform-3.0.03.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.

2
likes
70
pub points
31%
popularity

Publisher

Unknown

A Flutter plugin to open the apps page in an iranian android market.

Repository (GitHub)
View/report issues

Documentation

API reference

License

LICENSE

Dependencies

android_intent, flutter, get_version

More

Packages that depend on iran_appmarket