interactive_maps_marker 0.0.3
interactive_maps_marker: ^0.0.3 copied to clipboard

Easy to use Animated Maps Markers with detail card. Use it for store or any place locator.

41
likes
70 / 130
pub points
65 %
popularity

We analyzed this package on May 7, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 27 API elements (3.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:interactive_maps_marker/interactive_maps_marker.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: InteractiveMapsMarker.items, InteractiveMapsMarker.markerIcon, InteractiveMapsMarker.markerIconSelected

lib/interactive_maps_marker.dart:20:7

   ╷
20 │ class InteractiveMapsMarker extends StatefulWidget {
   │       ^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/interactive_maps_marker.dart

lib/interactive_maps_marker.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
google_maps_flutter^1.0.61.2.02.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
flutter_plugin_android_lifecycle-1.0.112.0.1
google_maps_flutter_platform_interface-1.2.02.0.4
meta-1.3.01.3.0
plugin_platform_interface-1.0.32.0.0
sky_engine-0.0.990.0.99
stream_transform-1.2.02.0.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.6` on google_maps_flutter does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions google_maps_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.

41
likes
70
pub points
65%
popularity

Publisher

atiq.dev

Easy to use Animated Maps Markers with detail card. Use it for store or any place locator.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, google_maps_flutter

More

Packages that depend on interactive_maps_marker