hgg_base 1.0.3
hgg_base: ^1.0.3 copied to clipboard

一个新的 flutter 基础库

0
likes
90/ 130
pub points
10%
popularity

We analyzed this package on Oct 18, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

The package description contains too many non-ASCII characters.

The site uses English as its primary language. The content of the description field in your package's pubspec.yaml should primarily contain characters used in English.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 104 out of 307 API elements (33.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:hgg_base/hgg_base.dart that imports:
  • package:hgg_base/src/widgets/x_states_layout.dart that imports:
  • package:hgg_base/src/widgets/x_getview.dart that imports:
  • package:hgg_base/src/model/x_base_model.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

lib/src/http/resp_data.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/utils/x_date_util.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bot_toast^4.0.14.0.14.0.1
dio^4.0.04.0.04.0.0
extended_image^5.1.25.1.25.1.2
flutterflutter0.0.00.0.0
flutter_screenutil^5.0.0+25.0.0+25.0.0+2
get^4.3.84.3.84.3.8
get_storage^2.0.32.0.32.0.3
logger^1.1.01.1.01.1.0
path_provider^2.0.52.0.52.0.5
pull_to_refresh^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
extended_image_library-3.1.03.1.0
ffi-1.1.21.1.2
file-6.1.26.1.2
http-0.13.40.13.4
http_client_helper-2.0.22.0.2
http_parser-4.0.04.0.0
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.2.92.2.9
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.