graphql_flutter 5.0.0
graphql_flutter: ^5.0.0 copied to clipboard

A GraphQL client for Flutter, bringing all the features from a modern GraphQL client to one easy to use package.

416
likes
75/ 130
pub points
97%
popularity

We analyzed this package 37 hours ago, and awarded it 75 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:3:1

  ╷
3 │ <a href="http://makeapullrequest.com"><img src="https://img.shields.io/badge/PRs-welcome-brightgreen.svg?style=flat-square" alt="PRs Welcome" /></a></p>
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 25 out of 67 API elements (37.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:graphql_flutter/graphql_flutter.dart that imports:
  • package:graphql_flutter/src/hive_init.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/hive_init.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/widgets/graphql_provider.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity_plus^1.0.11.4.02.1.0
flutterflutter0.0.00.0.0
gql_exec^0.3.00.3.00.3.0
graphql^5.0.05.0.05.0.0
hive^2.0.02.0.42.0.4
meta^1.3.01.7.01.7.0
path^1.8.01.8.01.8.0
path_provider^2.0.12.0.72.0.7
plugin_platform_interface^2.0.02.0.22.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
connectivity_plus_linux-1.1.11.1.1
connectivity_plus_macos-1.2.11.2.1
connectivity_plus_platform_interface-1.1.11.1.1
connectivity_plus_web-1.1.0+11.1.0+1
connectivity_plus_windows-1.2.01.2.0
crypto-3.0.13.0.1
dbus-0.6.60.6.6
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
gql-0.13.00.13.0
gql_dedupe_link-2.0.02.0.0
gql_error_link-0.2.00.2.0
gql_http_link-0.4.00.4.0
gql_link-0.4.00.4.0
gql_transform_link-0.2.00.2.0
http_parser-4.0.04.0.0
js-0.6.30.6.3
nm-0.4.10.4.1
normalize-0.5.50.5.5
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.42.0.4
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
petitparser-4.4.04.4.0
platform-3.1.03.1.0
process-4.2.44.2.4
rxdart-0.26.00.27.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
web_socket_channel-2.1.02.1.0
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.1` on connectivity_plus does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions connectivity_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Unable to access import.

Because:

  • package:graphql_flutter/graphql_flutter.dart that imports:
  • package:graphql_flutter/src/hive_init.dart that imports:
  • package:graphql/client.dart that imports:
  • package:graphql/src/graphql_client.dart that imports:
  • package:graphql/src/core/fetch_more.dart that imports:
  • package:graphql/src/core/query_manager.dart that imports:
  • package:graphql/src/core/mutation_options.dart that imports:
  • package:graphql/src/cache/cache.dart that imports:
  • package:graphql/src/cache/hive_store.dart that imports:
  • package:hive/hive.dart that imports:
  • package:hive/src/object/hive_object.dart that imports:
  • package:hive/src/object/hive_list_impl.dart that imports:
  • package:hive/src/hive_impl.dart that imports:
  • package:hive/src/backend/storage_backend.dart that imports:
  • package:hive/src/backend/js/backend_manager.dart that imports:
  • package:hive/src/backend/js/storage_backend_js.dart that imports:
  • dart:indexed_db where dart:indexed_db is inaccessible.
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

416
likes
75
pub points
97%
popularity

Publisher

zinoapp.com

A GraphQL client for Flutter, bringing all the features from a modern GraphQL client to one easy to use package.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

connectivity_plus, flutter, gql_exec, graphql, hive, meta, path, path_provider, plugin_platform_interface

More

Packages that depend on graphql_flutter