graphql 5.2.0-beta.7 copy "graphql: ^5.2.0-beta.7" to clipboard
graphql: ^5.2.0-beta.7 copied to clipboard

A stand-alone GraphQL client for Dart, bringing all the features from a modern GraphQL client to one easy to use package.

451
likes
110/ 140
pub points
98%
popularity

We analyzed this package 2 days ago, and awarded it 110 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/zino-hofmann/graphql-flutter/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

360 out of 624 API elements (57.7 %) have documentation comments.

Some symbols that are missing documentation: graphql, graphql.AuthLink.requestTransformer, graphql.AuthLink.transform, graphql.CacheMisconfigurationException.data, graphql.CacheMisconfigurationException.fragmentRequest.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/links/websocket_link/websocket_messages.dart:260:17

    ╷
260 │   bool operator ==(dynamic other) =>
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/links/websocket_link/websocket_messages.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/links/websocket_link/websocket_messages.dart:282:17

    ╷
282 │   bool operator ==(dynamic other) =>
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/links/websocket_link/websocket_messages.dart

OK
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.18.0
gql ^1.0.0 1.0.1-alpha+1715931674451 1.0.1-alpha+1715931674451
gql_dedupe_link ^2.0.3 2.0.4-alpha+1715521079596 2.0.4-alpha+1715521079596
gql_error_link ^1.0.0 1.0.0+1 1.0.0+1
gql_exec ^1.0.0 1.1.1-alpha+1699813812660 1.1.1-alpha+1699813812660
gql_http_link ^1.0.0 1.0.1+1 1.0.1+1
gql_link ^1.0.0 1.0.1-alpha+1715521079517 1.0.1-alpha+1715521079517
gql_transform_link ^1.0.0 1.0.0 1.0.0
hive ^2.1.0 2.2.3 2.2.3
http ^1.0.0 1.2.1 1.2.1
meta ^1.3.0 1.15.0 1.15.0
normalize ^0.8.2 0.8.2+1 0.9.1
path ^1.8.0 1.9.0 1.9.0
rxdart ^0.27.1 0.27.7 0.27.7
stream_channel ^2.1.0 2.1.2 2.1.2
uuid ^4.0.0 4.4.0 4.4.0
web_socket_channel ^2.3.0 2.4.5 3.0.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
crypto - 3.0.3 3.0.3
fixnum - 1.1.0 1.1.0
http_parser - 4.0.2 4.0.2
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.8.2` on normalize does not support the stable version `0.9.0`.

Try running dart pub upgrade --major-versions normalize to update the constraint.

The constraint `^2.3.0` on web_socket_channel does not support the stable version `3.0.0`, that was published 16 days ago.

When web_socket_channel is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions web_socket_channel to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

451
likes
110
pub points
98%
popularity

Publisher

verified publisherzino.company

A stand-alone GraphQL client for Dart, bringing all the features from a modern GraphQL client to one easy to use package.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, gql, gql_dedupe_link, gql_error_link, gql_exec, gql_http_link, gql_link, gql_transform_link, hive, http, meta, normalize, path, rxdart, stream_channel, uuid, web_socket_channel

More

Packages that depend on graphql