graphql 5.2.0-beta.7 copy "graphql: ^5.2.0-beta.7" to clipboard
graphql: ^5.2.0-beta.7 copied to clipboard

A stand-alone GraphQL client for Dart, bringing all the features from a modern GraphQL client to one easy to use package.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add graphql

With Flutter:

 $ flutter pub add graphql

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  graphql: ^5.2.0-beta.7

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:graphql/client.dart';
451
likes
110
pub points
98%
popularity

Publisher

verified publisherzino.company

A stand-alone GraphQL client for Dart, bringing all the features from a modern GraphQL client to one easy to use package.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, gql, gql_dedupe_link, gql_error_link, gql_exec, gql_http_link, gql_link, gql_transform_link, hive, http, meta, normalize, path, rxdart, stream_channel, uuid, web_socket_channel

More

Packages that depend on graphql