graphql 5.0.0
graphql: ^5.0.0 copied to clipboard

A stand-alone GraphQL client for Dart, bringing all the features from a modern GraphQL client to one easy to use package.

232
likes
105/ 130
pub points
97%
popularity

We analyzed this package 41 hours ago, and awarded it 105 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:3:1

  ╷
3 │ <a href="http://makeapullrequest.com"><img src="https://img.shields.io/badge/PRs-welcome-brightgreen.svg?style=flat-square" alt="PRs Welcome" /></a></p>
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 303 out of 549 API elements (55.2 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/exceptions/exceptions.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.15.01.15.0
gql^0.13.00.13.00.13.0
gql_dedupe_link^2.0.02.0.02.0.0
gql_error_link^0.2.00.2.00.2.0
gql_exec^0.3.00.3.00.3.0
gql_http_link^0.4.00.4.00.4.0
gql_link^0.4.00.4.00.4.0
gql_transform_link^0.2.00.2.00.2.0
hive^2.0.02.0.42.0.4
http^0.13.00.13.40.13.4
meta^1.3.01.7.01.7.0
normalize^0.5.30.5.50.5.5
path^1.8.01.8.01.8.0
rxdart^0.26.00.26.00.27.3
stream_channel^2.1.02.1.02.1.0
uuid^3.0.13.0.53.0.5
web_socket_channel^2.0.02.1.02.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
crypto-3.0.13.0.1
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.26.0` on rxdart does not support the stable version `0.27.0`.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.15.0.

232
likes
105
pub points
97%
popularity

Publisher

zinoapp.com

A stand-alone GraphQL client for Dart, bringing all the features from a modern GraphQL client to one easy to use package.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, gql, gql_dedupe_link, gql_error_link, gql_exec, gql_http_link, gql_link, gql_transform_link, hive, http, meta, normalize, path, rxdart, stream_channel, uuid, web_socket_channel

More

Packages that depend on graphql