google_maps_flutter_web 0.4.0+1 icon indicating copy to clipboard operation
google_maps_flutter_web: ^0.4.0+1 copied to clipboard

Platformweb

Web platform implementation of google_maps_flutter

128
likes
90/ 130
pub points
98%
popularity

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 138 out of 140 API elements (98.6 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Web

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:google_maps_flutter_web/google_maps_flutter_web.dart that declares support for platforms: Web.
Package does not support platform `iOS`.

Because:

  • package:google_maps_flutter_web/google_maps_flutter_web.dart that declares support for platforms: Web.
Package does not support platform `Windows`.

Because:

  • package:google_maps_flutter_web/google_maps_flutter_web.dart that declares support for platforms: Web.
Package does not support platform `Linux`.

Because:

  • package:google_maps_flutter_web/google_maps_flutter_web.dart that declares support for platforms: Web.
Package does not support platform `macOS`.

Because:

  • package:google_maps_flutter_web/google_maps_flutter_web.dart that declares support for platforms: Web.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

INFO: The operand can't be null, so the condition is always false.

lib/src/circles.dart:33:16

   ╷
33 │     if (circle == null) {
   │                ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/circles.dart

INFO: The operand can't be null, so the condition is always false.

lib/src/convert.dart:18:13

   ╷
18 │   if (color == null) {
   │             ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/convert.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_web_pluginsflutter0.0.00.0.0
google_maps^6.1.06.2.06.2.0
google_maps_flutter_platform_interface^2.2.02.2.12.2.1
sanitize_html^2.0.02.0.02.0.0
stream_transform^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.1
collection-1.16.01.16.0
csslib-0.17.20.17.2
html-0.15.00.15.0
js-0.6.40.6.4
js_wrapping-0.7.40.7.4
material_color_utilities-0.1.40.2.0
meta-1.7.01.8.0
path-1.8.21.8.2
plugin_platform_interface-2.1.22.1.2
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
term_glyph-1.2.11.2.1
vector_math-2.1.22.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Null safety support has one or more issues.

Unable to access import.

Because:

  • package:google_maps_flutter_web/google_maps_flutter_web.dart that imports:
  • package:google_maps_flutter_web/src/types.dart that imports:
  • package:google_maps/google_maps.dart that imports:
  • package:google_maps/src/generated/google_maps_core.js.g.dart that imports:
  • dart:web_gl where dart:web_gl is inaccessible.
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.14, Flutter 3.0.4, Dart 2.17.5.