google_maps_flutter 2.6.1 copy "google_maps_flutter: ^2.6.1" to clipboard
google_maps_flutter: ^2.6.1 copied to clipboard

A Flutter plugin for integrating Google Maps in iOS and Android applications.

3987
likes
140/ 140
pub points
100%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/flutter/flutter/issues?q=is%3Aissue+is%3Aopen+label%3A%22p%3A+maps%22 was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

296 out of 297 API elements (99.7 %) have documentation comments.

Some symbols that are missing documentation: google_maps_flutter.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `iOS`.

Because:

  • package:google_maps_flutter/google_maps_flutter.dart that imports:
  • package:google_maps_flutter_android/google_maps_flutter_android.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:google_maps_flutter/google_maps_flutter.dart that imports:
  • package:google_maps_flutter_android/google_maps_flutter_android.dart that declares support for platforms: Android.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
google_maps_flutter_android ^2.7.0 2.8.0 2.8.0
google_maps_flutter_ios ^2.5.0 2.6.0 2.6.0
google_maps_flutter_platform_interface ^2.6.0 2.7.0 2.7.0
google_maps_flutter_web ^0.5.6 0.5.7 0.5.7
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
csslib - 1.0.0 1.0.0
flutter_plugin_android_lifecycle - 2.0.19 2.0.19
flutter_web_plugins - 0.0.0 0.0.0
google_maps - 7.1.0 7.1.0
html - 0.15.4 0.15.4
js - 0.6.7 0.7.1
js_wrapping - 0.7.4 0.7.4
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sanitize_html - 2.1.0 2.1.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stream_transform - 2.1.0 2.1.0
term_glyph - 1.2.1 1.2.1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.