gits_inspector 3.2.1 copy "gits_inspector: ^3.2.1" to clipboard
gits_inspector: ^3.2.1 copied to clipboard

A simple in-app for GitsHttp inspector. Intercepts and persists all HTTP requests and responses inside your application, and provides a UI for inspecting their content.

3
likes
150/ 160
pub points
5%
popularity

We analyzed this package 29 hours ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

53 out of 55 API elements (96.4 %) have documentation comments.

Some symbols that are missing documentation: gits_inspector, gits_inspector.GitsInspector.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:gits_inspector/gits_inspector.dart that imports:
  • package:gits_inspector/src/gits_inspector.dart that imports:
  • package:gits_inspector/src/pages/gits_inspector_page.dart that imports:
  • package:gits_inspector/src/service/inspector_service.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:gits_inspector/gits_inspector.dart that imports:
  • package:gits_inspector/src/gits_inspector.dart that imports:
  • package:gits_inspector/src/pages/gits_inspector_page.dart that imports:
  • package:gits_inspector/src/service/inspector_service.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `macOS`.

Because:

  • package:gits_inspector/gits_inspector.dart that imports:
  • package:gits_inspector/src/gits_inspector.dart that imports:
  • package:gits_inspector/src/pages/gits_inspector_page.dart that imports:
  • package:gits_inspector/src/pages/gits_inspector_detail_page.dart that imports:
  • package:share_plus/share_plus.dart that imports:
  • package:share_plus/src/share_plus_windows.dart that imports:
  • package:url_launcher_windows/url_launcher_windows.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:gits_inspector/gits_inspector.dart that imports:
  • package:gits_inspector/src/gits_inspector.dart that imports:
  • package:gits_inspector/src/pages/gits_inspector_page.dart that imports:
  • package:gits_inspector/src/service/inspector_service.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:gits_inspector/gits_inspector.dart that imports:
  • package:gits_inspector/src/gits_inspector.dart that imports:
  • package:gits_inspector/src/pages/gits_inspector_page.dart that imports:
  • package:gits_inspector/src/pages/gits_inspector_detail_page.dart that imports:
  • package:share_plus/share_plus.dart that imports:
  • package:share_plus/src/share_plus_windows.dart that imports:
  • package:url_launcher_windows/url_launcher_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:gits_inspector/gits_inspector.dart that imports:
  • package:gits_inspector/src/gits_inspector.dart that imports:
  • package:gits_inspector/src/pages/gits_inspector_page.dart that imports:
  • package:gits_inspector/src/pages/gits_inspector_detail_page.dart that imports:
  • package:share_plus/share_plus.dart that imports:
  • package:share_plus/src/share_plus_windows.dart that imports:
  • package:url_launcher_windows/url_launcher_windows.dart that declares support for platforms: Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_local_notifications ^16.2.0 16.3.3 17.1.2
intl ^0.18.1 0.18.1 0.19.0
sensors_plus ^4.0.2 4.0.2 5.0.1
share_plus ^7.2.1 7.2.2 9.0.0
sqflite ^2.3.0 2.3.3+1 2.3.3+1
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
cross_file - 0.3.4+1 0.3.4+1
crypto - 3.0.3 3.0.3
dbus - 0.7.10 0.7.10
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
flutter_local_notifications_linux - 4.0.0+1 4.0.0+1
flutter_local_notifications_platform_interface - 7.1.0 7.1.0
flutter_web_plugins - 0.0.0 0.0.0
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
mime - 1.0.5 1.0.5
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.5 2.2.5
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
sensors_plus_platform_interface - 1.2.0 1.2.0
share_plus_platform_interface - 3.4.0 4.0.0
sky_engine - 0.0.99 0.0.99
sprintf - 7.0.0 7.0.0
sqflite_common - 2.5.4 2.5.4
synchronized - 3.1.0+1 3.1.0+1
timezone - 0.9.3 0.9.3
typed_data - 1.3.2 1.3.2
url_launcher_linux - 3.1.1 3.1.1
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^16.2.0` on flutter_local_notifications does not support the stable version `17.0.0`.

Try running dart pub upgrade --major-versions flutter_local_notifications to update the constraint.

The constraint `^0.18.1` on intl does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

3
likes
150
pub points
5%
popularity

Publisher

verified publishergits.id

A simple in-app for GitsHttp inspector. Intercepts and persists all HTTP requests and responses inside your application, and provides a UI for inspecting their content.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, flutter_local_notifications, intl, sensors_plus, share_plus, sqflite

More

Packages that depend on gits_inspector