fuels 1.20.1 copy "fuels: ^1.20.1" to clipboard
fuels: ^1.20.1 copied to clipboard

Dart FFI bridge to Fuel Rust SDK

2
likes
60/ 140
pub points
23%
popularity

We analyzed this package 29 hours ago, and awarded it 60 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: AGPL-3.0.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

16 out of 180 API elements (8.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: fuels.Bech32Address, fuels.Bech32Address.Bech32Address, fuels.Bech32Address.bridge, fuels.Bech32Address.fromB256String, fuels.Bech32Address.fromBech32String.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:fuels/fuels.dart that imports:
  • package:fuels/src/fuels_base.dart that imports:
  • package:fuels/src/bridge_generated.dart that imports:
  • dart:ffi
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 1823 issues. Showing the first 2:

ERROR: Undefined name 'optionalTypeArgs' used as an annotation.

lib/src/bridge_generated.freezed.dart:19:3

   ╷
19 │   @optionalTypeArgs
   │   ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/bridge_generated.freezed.dart

ERROR: Undefined class 'U8Array32'.

lib/src/bridge_generated.freezed.dart:22:13

   ╷
22 │             U8Array32 id,
   │             ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/bridge_generated.freezed.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.17.0 1.18.0 1.18.0
ffi ^2.0.1 2.1.2 2.1.2
flutter_rust_bridge 1.82.6 1.82.6 1.82.6
freezed_annotation ^2.2.0 2.4.1 2.4.1
meta ^1.8.0 1.14.0 1.14.0
uuid ^4.2.1 4.4.0 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.4.10 3.4.10
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
build_cli_annotations - 2.1.0 2.1.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
fixnum - 1.1.0 1.1.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
mime - 1.0.5 1.0.5
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
pointycastle - 3.8.0 3.8.0
pool - 1.5.1 1.5.1
puppeteer - 3.8.0 3.8.0
shelf - 1.4.1 1.4.1
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 1.0.4 1.0.4
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
tuple - 2.0.2 2.0.2
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 2.4.5
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.