fort 0.1.3 copy "fort: ^0.1.3" to clipboard
fort: ^0.1.3 copied to clipboard

An application state management library.

0
likes
110/ 140
pub points
22%
popularity

We analyzed this package 31 hours ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

303 out of 355 API elements (85.4 %) have documentation comments.

Some symbols that are missing documentation: fort, fort.BoxCollection, fort.BoxCollection.BoxCollection, fort.BoxCollection.boxNames, fort.BoxCollection.close.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:fort/fort.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:fort/fort.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:fort/fort.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:fort/fort.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: The import of 'package:hive/hive.dart' is unnecessary because all of the used elements are also provided by the import of 'package:hive_flutter/hive_flutter.dart'.

lib/fort.dart:5:8

  ╷
5 │ import 'package:hive/hive.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/fort.dart

INFO: Empty catch block.

lib/fort.dart:101:14

    ╷
101 │     }catch(e){}
    │              ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/fort.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_redux ^0.8.2 0.8.2 0.10.0
hive ^2.0.4 2.2.3 2.2.3
hive_flutter ^1.1.0 1.1.0 1.1.0
redux ^5.0.0 5.0.0 5.0.0
redux_persist ^0.9.0 0.9.0 0.9.0
redux_persist_flutter ^0.9.0 0.9.0 0.9.0
redux_thunk ^0.4.0 0.4.0 0.4.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences - 2.2.3 2.2.3
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
synchronized - 3.1.0+1 3.1.0+1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.8.2` on flutter_redux does not support the stable version `0.9.0`.

Try running dart pub upgrade --major-versions flutter_redux to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.