flutterflow_cli 0.0.17 copy "flutterflow_cli: ^0.0.17" to clipboard
flutterflow_cli: ^0.0.17 copied to clipboard

Command-line client for FlutterFlow. Export code from FlutterFlow projects.

57
likes
140/ 140
pub points
73%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2 out of 6 API elements (33.3 %) have documentation comments.

Some symbols that are missing documentation: flutterflow_cli, flutterflow_cli.exportCode, flutterflow_cli.extractArchiveToCurrentDirectory, flutterflow_cli.kDefaultEndpoint.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutterflow_cli/flutterflow_cli.dart that imports:
  • package:flutterflow_cli/src/flutterflow_api_client.dart that imports:
  • package:archive/archive_io.dart that imports:
  • package:archive/src/io/zip_file_encoder.dart that imports:
  • package:archive/src/io/output_file_stream.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
archive ^3.3.5 3.4.10 3.4.10
args ^2.3.0 2.5.0 2.5.0
http ^1.1.0 1.2.1 1.2.1
path ^1.8.0 1.9.0 1.9.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
http_parser - 4.0.2 4.0.2
js - 0.7.1 0.7.1
meta - 1.14.0 1.14.0
pointycastle - 3.9.0 3.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

57
likes
140
pub points
73%
popularity

Publisher

verified publisherflutterflow.io

Command-line client for FlutterFlow. Export code from FlutterFlow projects.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

archive, args, http, path

More

Packages that depend on flutterflow_cli