flutterfire_cli 1.0.0 copy "flutterfire_cli: ^1.0.0" to clipboard
flutterfire_cli: ^1.0.0 copied to clipboard

FlutterFire CLI for configuring Firebase on your application.

119
likes
140/ 160
pub points
95%
popularity

We analyzed this package 15 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1 out of 4 API elements (25.0 %) have documentation comments.

Some symbols that are missing documentation: flutterfire_cli, version.g, version.g.cliVersion.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ansi_styles ^0.3.2+1 0.3.2+1 0.3.2+1
args ^2.3.0 2.5.0 2.5.0
ci ^0.1.0 0.1.0 0.1.0
cli_util ^0.4.0 0.4.1 0.4.1
deep_pick ^1.0.0 1.0.0 1.0.0
file ^6.1.2 6.1.4 7.0.0
http ^0.13.5 0.13.6 1.2.2
interact ^2.1.1 2.2.0 2.2.0
meta ^1.7.0 1.15.0 1.15.0
path ^1.8.0 1.9.0 1.9.0
platform ^3.0.2 3.1.5 3.1.5
pub_updater ^0.2.2 0.2.4 0.4.0
pubspec ^2.1.0 2.3.0 2.3.0
xml ^6.1.0 6.5.0 6.5.0
yaml ^3.1.2 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.19.0 1.19.0
dart_console - 1.2.0 4.1.0
ffi - 2.1.2 2.1.2
http_parser - 4.1.0 4.1.0
intl - 0.18.1 0.19.0
json_annotation - 4.9.0 4.9.0
matcher - 0.12.16+1 0.12.16+1
petitparser - 6.0.2 6.0.2
process - 4.2.4 5.0.2
pub_semver - 2.1.4 2.1.4
quiver - 3.2.1 3.2.1
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.3 0.7.3
tint - 2.0.1 2.0.1
typed_data - 1.3.2 1.3.2
uri - 1.0.0 1.0.0
win32 - 5.5.1 5.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^6.1.2` on file does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions file to update the constraint.

The constraint `^0.13.5` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.