flutter_validate 1.0.2

Flutter Android iOS web

A Flutter package for performing validation using a fluent interface approach.

4
likes
70 / 110
pub points
72 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 71 API elements (14.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/validationResult.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/validators/dateValidator.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
intl^0.15.70.15.80.16.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
meta-1.1.81.2.3
path-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.15.7` on intl does not support the latest published version `0.16.1`

pubspec.yaml:13:9

   ╷
13 │   intl: ^0.15.7
   │         ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

4
likes
70
pub points
72%
popularity

A Flutter package for performing validation using a fluent interface approach.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ebrightster@gmail.com

License

unknown (LICENSE)

Dependencies

flutter, intl

More

Packages that depend on flutter_validate