flutter_validate 1.0.2

flutter_validate #

A Flutter package for performing validation using a fluent interface approach.

Getting Started #

Take a look at the example Flutter project accompanying this package as well as the unit tests. But a full-fledged getting started section is coming soon!


  • Expand number and variety of validators. Including:
    • Credit Card: A validator that checks if an input string is a well-formed credit card number.
    • Comparison validators such as greater than, less than, greater than or equal to, etc.
  • Support Localization/Internationalization

1.0.0 Initial Version #

  • Fluent validation library released.

1.0.1 Update #

  • Library update
  • Changed validationResult.errorText to return null instead of empty string if no validation errors exist.

1.0.2 Update #

  • validationResult now respects an optional passed in delimiter. Defaults to a space.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_validate: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_validate/flutter_validate.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health suggestions

Format lib/src/validationResult.dart.

Run flutter format to format lib/src/validationResult.dart.

Format lib/src/validators/dateValidator.dart.

Run flutter format to format lib/src/validators/dateValidator.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (intl).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_validate.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
intl ^0.15.7 0.15.8 0.16.1
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
path 1.6.4
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies