A Flutter package for performing validation using a fluent interface approach.
Take a look at the example Flutter project accompanying this package as well as the unit tests. But a full-fledged getting started section is coming soon!
Add this to your package's pubspec.yaml file:
dependencies: flutter_validate: ^1.0.1
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.0.1||Jun 26, 2019|
|1.0.0||Mar 16, 2019|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jun 26, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
lib/src/validationResult.dart. (-0.50 points)
lib/src/validationResult.dart reported 1 hint:
line 5 col 10: The value of the field '_delimiter' isn't used.
flutter format to format
Support latest dependencies. (-5 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 1 dependency.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
flutter_validate.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.