flutter_ume_kit_show_code 1.0.0+1 copy "flutter_ume_kit_show_code: ^1.0.0+1" to clipboard
flutter_ume_kit_show_code: ^1.0.0+1 copied to clipboard

Show Code kit for flutter_ume.

1
likes
80/ 140
pub points
87%
popularity

We analyzed this package 9 hours ago, and awarded it 80 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

3 out of 63 API elements (4.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: code_display_service, code_display_service.CodeDisplayService, code_display_service.CodeDisplayService.CodeDisplayService, code_display_service.CodeDisplayService.getIdWithClassName, code_display_service.CodeDisplayService.getScriptIdWithFileName.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_ume_kit_show_code/flutter_ume_kit_show_code.dart that imports:
  • package:flutter_ume_kit_show_code/show_code/show_code.dart that imports:
  • package:share/share.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_ume_kit_show_code/flutter_ume_kit_show_code.dart that imports:
  • package:flutter_ume_kit_show_code/show_code/show_code.dart that imports:
  • package:share/share.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_ume_kit_show_code/flutter_ume_kit_show_code.dart that imports:
  • package:flutter_ume_kit_show_code/show_code/show_code.dart that imports:
  • package:share/share.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_ume_kit_show_code/flutter_ume_kit_show_code.dart that imports:
  • package:flutter_ume_kit_show_code/show_code/show_code.dart that imports:
  • package:share/share.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

WARNING: The operand can't be null, so the condition is always 'false'.

lib/show_code/page_info_helper.dart:53:17

   ╷
53 │     return size == null ? double.maxFinite : size.width * size.height;
   │                 ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/show_code/page_info_helper.dart

WARNING: The operand can't be null, so the condition is always 'true'.

lib/show_code/show_code.dart:174:40

    ╷
174 │                           if (codeList != null && codeList.isNotEmpty) {
    │                                        ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/show_code/show_code.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_ume >=1.0.0 <2.0.0 1.1.1 1.1.2
share ^2.0.4 2.0.4 2.0.4
string_scanner ^1.1.0 1.2.0 1.2.0
vm_service ^7.1.1 7.5.0 14.2.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_localizations - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
intl - 0.18.1 0.19.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
mime - 1.0.5 1.0.5
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences - 2.2.3 2.2.3
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
term_glyph - 1.2.1 1.2.1
tuple - 2.0.2 2.0.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^7.1.1` on vm_service does not support the stable version `8.1.0`.

Try running dart pub upgrade --major-versions vm_service to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.