flutter_transmission 0.0.3
flutter_transmission: ^0.0.3 copied to clipboard

Flutter Android iOS Linux macOS Windows

Flutter package to talk to a Transmission torrent instance, for a pure dart package please check [transmission](https://github.com/mylisabox/transmission)

1
likes
90 / 110
pub points
28 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 23 out of 48 API elements (47.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:flutter_transmission/flutter_transmission.dart that imports:
  • package:flutter_transmission/src/flutter_transmission.dart that imports:
  • package:flutter_svg/flutter_svg.dart that imports:
  • package:flutter_svg/svg.dart that imports:
  • package:flutter_svg/src/picture_provider.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/flutter_transmission.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/flutter_transmission.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_hooks>=0.13.1 <1.0.00.15.00.16.0
flutter_mobx>=1.1.0 <2.0.01.1.0+21.1.0+2
flutter_svg>=0.18.0 <1.0.00.19.10.19.3
mobx>=1.2.1 <2.0.01.2.1+41.2.1+4
provider>=4.3.2 <5.0.04.3.34.3.3
transmission>=0.0.2 <1.0.00.0.20.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
convert-2.1.13.0.0
dio-3.0.103.0.10
http_parser-3.1.44.0.0
meta-1.3.0-nullsafety.31.3.0
nested-0.0.41.0.0
path-1.7.01.8.0
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
petitparser-3.1.04.0.2
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0
xml-4.5.15.0.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

1
likes
90
pub points
28%
popularity

Publisher

mylisabox.com

Flutter package to talk to a Transmission torrent instance, for a pure dart package please check [transmission](https://github.com/mylisabox/transmission)

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_hooks, flutter_mobx, flutter_svg, mobx, provider, transmission

More

Packages that depend on flutter_transmission