flutter_tk 1.0.4
flutter_tk: ^1.0.4 copied to clipboard

flutter_tk

2
likes
65/ 130
pub points
53%
popularity

We analyzed this package 19 hours ago, and awarded it 65 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 92 out of 478 API elements (19.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:flutter_tk/form/fields/model_text_field.dart that declares support for platforms: Android, iOS, Web.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 19 issues. Showing the first 2:

lib/form/fields/model_text_field.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/form/tk_form.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.15.01.15.0
dio^4.0.04.0.44.0.4
email_validator^2.0.12.0.12.0.1
fancy_shimmer_image^2.0.0+12.0.1+12.0.1+1
fbutton^2.0.12.0.12.0.1
file_picker^4.0.04.2.74.2.7
flutterflutter0.0.00.0.0
flutter_easyrefresh^2.2.12.2.12.2.1
flutter_focus_watcher^2.0.02.0.02.0.0
flutter_spinkit^5.0.05.1.05.1.0
flutter_web_pluginsflutter0.0.00.0.0
gap^2.0.02.0.02.0.0
get^4.3.44.5.14.5.1
logger^1.0.01.1.01.1.0
lottie^1.1.01.2.11.2.1
modal_bottom_sheet^2.0.02.0.02.0.0
smart_color^0.2.20.2.20.2.2
supercharged^2.0.02.1.12.1.1
validators^3.0.03.0.03.0.0
visibility_detector^0.2.00.2.20.2.2
wechat_assets_picker^5.5.85.5.86.2.4
wechat_camera_picker^2.2.02.6.12.6.1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.63.1.6
async-2.8.12.8.2
boolean_selector-2.1.02.1.0
cached_network_image-3.2.03.2.0
cached_network_image_platform_interface-1.0.01.0.0
cached_network_image_web-1.0.11.0.1
camera-0.9.4+50.9.4+5
camera_platform_interface-2.1.12.1.1
camera_web-0.2.1+10.2.1+1
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
cross_file-0.3.20.3.2
crypto-3.0.13.0.1
csslib-0.17.10.17.1
extended_image-4.2.15.1.3
extended_image_library-3.1.03.1.0
fake_async-1.2.01.2.0
fcontrol-1.0.11.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_blurhash-0.6.00.6.0
flutter_cache_manager-3.3.03.3.0
flutter_plugin_android_lifecycle-2.0.52.0.5
html-0.15.00.15.0
http-0.13.40.13.4
http_client_helper-2.0.22.0.2
http_parser-4.0.04.0.0
js-0.6.30.6.3
matcher-0.12.100.12.11
meta-1.7.01.7.0
nested-1.0.01.0.0
octo_image-1.0.11.0.1
path-1.8.01.8.0
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.42.0.4
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
photo_manager-1.3.101.3.10
pigment-1.0.41.0.4
platform-3.1.03.1.0
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
provider-5.0.06.0.1
quiver-3.0.1+13.0.1+1
rxdart-0.27.30.27.3
shimmer-2.0.02.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.12.0.1
sqflite_common-2.0.1+12.0.1+1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
supercharged_dart-2.1.12.1.1
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
test_api-0.4.20.4.8
typed_data-1.3.01.3.0
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
video_player-2.2.72.2.7
video_player_platform_interface-4.2.04.2.0
video_player_web-2.0.42.0.4
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.5.8` on wechat_assets_picker does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions wechat_assets_picker to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • flutter_tk that depends on:
  • fbutton that doesn't opt in to null safety
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.