flutter_starter_cli 0.0.1-dev.4 copy "flutter_starter_cli: ^0.0.1-dev.4" to clipboard
flutter_starter_cli: ^0.0.1-dev.4 copied to clipboard

A command line tool that provides ease of setting up a Flutter project.

28
likes
130/ 160
pub points
12%
popularity

We analyzed this package 41 hours ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: flutter_starter_cli,
    • contains a version property, and,
    • does not contain a publish_to property.

Could not find any pubspec.yaml in the repository.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1 out of 1 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The referenced identifier is a wildcard.

lib/src/cli/actions.dart:43:20

   ╷
43 │         var file = _;
   │                    ^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/cli/actions.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.3.1 2.5.0 2.5.0
mason_logger ^0.2.2 0.2.15 0.2.15
path ^1.8.2 1.9.0 1.9.0
pub_updater ^0.2.2 0.2.4 0.4.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.19.0 1.19.0
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
http - 0.13.6 1.2.1
http_parser - 4.1.0 4.1.0
io - 1.0.4 1.0.4
json_annotation - 4.9.0 4.9.0
meta - 1.15.0 1.15.0
platform - 3.1.5 3.1.5
process - 4.2.4 5.0.2
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
win32 - 5.5.1 5.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.2.2` on pub_updater does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions pub_updater to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.

28
likes
130
pub points
12%
popularity

Publisher

verified publishergeekyants.com

A command line tool that provides ease of setting up a Flutter project.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

args, mason_logger, path, pub_updater

More

Packages that depend on flutter_starter_cli