flutter_settings_screens 0.2.2+1 icon indicating copy to clipboard operation
flutter_settings_screens: ^0.2.2+1 copied to clipboard

A Simple plugin to implement settings UI screens for your flutter apps. Customize what you want, From UI elements, behaviour or underlying storage library.

163
likes
100/ 140
pub points
94%
popularity

We analyzed this package 3 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 182 out of 253 API elements (71.9 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: 'headline6' is deprecated and shouldn't be used. Use titleLarge instead. This feature was deprecated after v3.1.0-0.0.pre.

lib/src/utils/widget_utils.dart:14:33

   ╷
14 │     Theme.of(context).textTheme.headline6.copyWith(fontSize: 16.0);
   │                                 ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/utils/widget_utils.dart

INFO: 'subtitle2' is deprecated and shouldn't be used. Use titleSmall instead. This feature was deprecated after v3.1.0-0.0.pre.

lib/src/utils/widget_utils.dart:18:6

   ╷
18 │     .subtitle2
   │      ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/utils/widget_utils.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_material_color_picker^1.0.51.1.0+21.1.0+2
path_provider^2.0.12.0.122.0.12
pedantic^1.11.01.11.11.11.1
provider^5.0.05.0.06.0.5
shared_preferences^2.0.52.0.172.0.17
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.17.01.17.1
ffi-2.0.12.0.1
file-6.1.46.1.4
flutter_web_plugins-0.0.00.0.0
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
nested-1.0.01.0.0
path-1.8.31.8.3
path_provider_android-2.0.222.0.22
path_provider_foundation-2.1.12.1.1
path_provider_linux-2.1.72.1.7
path_provider_platform_interface-2.0.52.0.5
path_provider_windows-2.1.32.1.3
platform-3.1.03.1.0
plugin_platform_interface-2.1.32.1.3
process-4.2.44.2.4
shared_preferences_android-2.0.152.0.15
shared_preferences_foundation-2.1.32.1.3
shared_preferences_linux-2.1.32.1.3
shared_preferences_platform_interface-2.1.02.1.0
shared_preferences_web-2.0.42.0.4
shared_preferences_windows-2.1.32.1.3
sky_engine-0.0.990.0.99
vector_math-2.1.42.1.4
win32-3.1.34.1.1
xdg_directories-0.2.0+30.2.0+3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.0.0` on provider does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

163
likes
100
pub points
94%
popularity

Publisher

unverified uploader

A Simple plugin to implement settings UI screens for your flutter apps. Customize what you want, From UI elements, behaviour or underlying storage library.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, flutter_material_color_picker, path_provider, pedantic, provider, shared_preferences

More

Packages that depend on flutter_settings_screens