flutter_qweather 0.0.11 copy "flutter_qweather: ^0.0.11" to clipboard
flutter_qweather: ^0.0.11 copied to clipboard

A qweather Flutter plugin. Free use of qweather api. Only Android and IOS platforms are supported.

5
likes
130/ 140
pub points
42%
popularity

We analyzed this package 6 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

444 out of 523 API elements (84.9 %) have documentation comments.

Some symbols that are missing documentation: air, air.AirDaily.AirDaily.fromMap, air.AirNow.AirNow.fromMap, air.AirNowResp.stations, air.StationNow.StationNow.fromMap.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_qweather/flutter_qweather.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_qweather/flutter_qweather.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_qweather/flutter_qweather.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_qweather/flutter_qweather.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/apis/air_api.dart:1:1

  ╷
1 │ part of qweather;
  │ ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/apis/air_api.dart

INFO: The part-of directive uses a library name.

lib/apis/astronomy_api.dart:1:1

  ╷
1 │ part of qweather;
  │ ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/apis/astronomy_api.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

5
likes
130
pub points
42%
popularity

Publisher

verified publisherfluttercandies.com

A qweather Flutter plugin. Free use of qweather api. Only Android and IOS platforms are supported.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_qweather