flutter_osm_plugin 0.6.7
flutter_osm_plugin: ^0.6.7 copied to clipboard

Flutter Android iOS

openStreetMap plugin for flutter apps (only Android for now, iOS will be supported in future)

16
likes
90 / 110
pub points
79 %
popularity

We analyzed this package on Feb 28, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 37 out of 121 API elements (30.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_osm_plugin/flutter_osm_plugin.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/common/utilities.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/controller/osm_controller.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
after_layout^1.0.7+21.0.7+21.0.7+2
dio^3.0.103.0.103.0.10
flutterflutter0.0.00.0.0
flutter_plugin_android_lifecycle^1.0.111.0.112.0.0
location_permissions^3.0.0+13.0.0+13.0.0+1
plugin_platform_interface^1.0.31.0.32.0.0
stream_transform^1.2.01.2.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
http_parser-3.1.44.0.0
meta-1.3.0-nullsafety.31.3.0
path-1.7.01.8.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.0.11` on flutter_plugin_android_lifecycle does not support the stable version `2.0.0`, that was published 8 days ago.

When flutter_plugin_android_lifecycle is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_plugin_android_lifecycle to update the constraint.

The constraint `^1.0.3` on plugin_platform_interface does not support the stable version `2.0.0`, that was published 9 days ago.

When plugin_platform_interface is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions plugin_platform_interface to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.