flutter_ios_calculator 0.1.0 copy "flutter_ios_calculator: ^0.1.0" to clipboard
flutter_ios_calculator: ^0.1.0 copied to clipboard

iOS 10 and iOS 11/12 style calculators for Flutter

2
likes
60/ 140
pub points
10%
popularity

We analyzed this package 6 days ago, and awarded it 60 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

22 out of 144 API elements (15.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: custom_button, custom_button.CustomButton, custom_button.CustomButton.CustomButton, custom_button.CustomButton.child, custom_button.CustomButton.color.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_ios_calculator/flutter_ios_calculator.dart that imports:
  • package:flutter_ios_calculator/ios12_calculator.dart that imports:
  • package:flutter_device_type/flutter_device_type.dart that imports:
  • dart:io
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 22 issues. Showing the first 2:

ERROR: Missing concrete implementations of 'getter WidgetsLocalizations.reorderItemDown', 'getter WidgetsLocalizations.reorderItemLeft', 'getter WidgetsLocalizations.reorderItemRight', 'getter WidgetsLocalizations.reorderItemToEnd', and 2 more.

lib/generated/i18n.dart:11:7

   ╷
11 │ class S implements WidgetsLocalizations {
   │       ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/generated/i18n.dart

ERROR: Missing concrete implementations of 'getter WidgetsLocalizations.reorderItemDown', 'getter WidgetsLocalizations.reorderItemLeft', 'getter WidgetsLocalizations.reorderItemRight', 'getter WidgetsLocalizations.reorderItemToEnd', and 2 more.

lib/generated/i18n.dart:26:7

   ╷
26 │ class $en extends S {
   │       ^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/generated/i18n.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
auto_size_text ^3.0.0 3.0.0 3.0.0
flutter flutter 0.0.0 0.0.0
flutter_device_type ^0.4.0 0.4.0 0.4.0
intl ^0.17.0 0.17.0 0.19.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

2
likes
60
pub points
10%
popularity

Publisher

unverified uploader

iOS 10 and iOS 11/12 style calculators for Flutter

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

auto_size_text, flutter, flutter_device_type, intl

More

Packages that depend on flutter_ios_calculator