flutter_gallery 2.4.0+20400
flutter_gallery: ^2.4.0+20400 copied to clipboard

unlisted

A resource to help developers evaluate and use Flutter.

4
likes
20 / 110
pub points
84 %
popularity

We analyzed this package on Jan 18, 2021, and awarded it 20 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run pub get for more information.

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 43852 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:flutter/material.dart'.

lib/benchmarks/gallery_automator.dart:7:8

  ╷
7 │ import 'package:flutter/material.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/benchmarks/gallery_automator.dart

ERROR: Target of URI doesn't exist: 'package:flutter_test/flutter_test.dart'.

lib/benchmarks/gallery_automator.dart:8:8

  ╷
8 │ import 'package:flutter_test/flutter_test.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/benchmarks/gallery_automator.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
Because flutter_gallery depends on flutter_localizations any from sdk which depends on intl 0.17.0-nullsafety.2, intl 0.17.0-nullsafety.2 is required.
So, because flutter_gallery depends on intl ^0.16.1, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs