flutter_fuels 0.0.34 copy "flutter_fuels: ^0.0.34" to clipboard
flutter_fuels: ^0.0.34 copied to clipboard

Flutter Plugin for Fuel SDK

2
likes
100/ 140
pub points
37%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: AGPL-3.0.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

26 out of 458 API elements (5.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: base_fuel_utils, base_fuel_utils.BaseFuelUtils, base_fuel_utils.BaseFuelUtils.BaseFuelUtils, base_fuel_utils.BaseFuelUtils.b256FromBech32String, base_fuel_utils.BaseFuelUtils.bech32FromB256String.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/wallet/platform_impl/mobile_wallet.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bip39_mnemonic ^3.0.6 3.0.6 3.0.6
convert ^3.1.1 3.1.1 3.1.1
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
fuels ^1.20.1 1.20.1 1.20.1
js ^0.6.5 0.6.7 0.7.1
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.4.10 3.4.10
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
build_cli_annotations - 2.1.0 2.1.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
fixnum - 1.1.0 1.1.0
flutter_rust_bridge - 1.82.6 1.82.6
freezed_annotation - 2.4.1 2.4.1
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
mime - 1.0.5 1.0.5
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
pointycastle - 3.9.0 3.9.0
pool - 1.5.1 1.5.1
puppeteer - 3.8.0 3.8.0
shelf - 1.4.1 1.4.1
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 1.0.4 1.0.4
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
tuple - 2.0.2 2.0.2
typed_data - 1.3.2 1.3.2
unorm_dart - 0.2.0 0.3.0
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 2.4.5
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.5` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.