flutter_flicker 0.93.0
flutter_flicker: ^0.93.0 copied to clipboard

App state, routing and other shared patterns for Code Collective flutter projects

3
likes
90/ 130
pub points
49%
popularity

We analyzed this package 12 hours ago, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 26 out of 341 API elements (7.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform `Android`.

Because:

  • package:flutter_flicker/flutter_flicker.dart that imports:
  • package:flutter_flicker/state/base_entity_logic.dart that imports:
  • package:flutter_flicker/state/base_logic.dart that imports:
  • package:flutter_flicker/navigation/route_configuration.dart that imports:
  • package:flutter_flicker/configuration/configuration.dart that imports:
  • package:flutter_flicker/flutter_flicker_controls.dart that imports:
  • package:flutter_flicker/controls/form_input/text_input.dart that imports:
  • package:google_fonts/google_fonts.dart that imports:
  • package:google_fonts/src/google_fonts_base.dart that imports:
  • package:google_fonts/src/file_io_desktop_and_mobile.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

lib/controls/form_input/date_input.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/controls/form_input/decorator_utils.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_riverpod^0.14.00.14.0+31.0.1
google_fonts>=1.0.0 <3.0.02.1.02.1.0
intl>=0.16.0 <1.0.00.17.00.17.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
freezed_annotation-0.14.31.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
json_annotation-4.4.04.4.0
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.32.0.3
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
platform-3.1.03.1.0
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
riverpod-0.14.0+31.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
state_notifier-0.7.10.7.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.14.0` on flutter_riverpod does not support the stable version `1.0.0`, that was published 27 days ago.

When flutter_riverpod is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_riverpod to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

3
likes
90
pub points
49%
popularity

Publisher

codecollective.com

App state, routing and other shared patterns for Code Collective flutter projects

Homepage (insecure)

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, flutter_riverpod, google_fonts, intl

More

Packages that depend on flutter_flicker