flutter_degen 0.4.4+2
flutter_degen: ^0.4.4+2

Dart native

The Flutter code generator for your delegates

0
likes
80 / 110
pub points
1 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 8 API elements (25.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:flutter_degen/build.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The value of the local variable 'parent' isn't used.

lib/src/degenerator.dart:20:11

   ╷
20 │     final parent = field.thisOrAncestorOfType<ClassElement>();
   │           ^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/degenerator.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzerany0.40.60.41.0
args^1.6.01.6.01.6.0
build^1.3.01.5.11.5.1
build_configany0.4.30.4.3
build_runner^1.10.11.10.61.10.6
color^2.1.12.1.12.1.1
dart_style^1.3.61.3.101.3.10
dartx^0.5.00.5.00.5.0
mime^0.9.70.9.70.9.7
path^1.7.01.7.01.7.0
source_genany0.9.80.9.8
xml^4.2.04.5.14.5.1
yaml^2.2.12.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.013.0.0
async-2.4.22.4.2
build_daemon-2.1.42.1.4
build_resolvers-1.4.31.4.3
build_runner_core-6.1.16.1.1
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
characters-1.0.01.0.0
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
cli_util-0.2.00.2.0
code_builder-3.5.03.5.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
file-5.2.15.2.1
fixnum-0.10.110.10.11
glob-1.2.01.2.0
graphs-0.2.00.2.0
http_multi_server-2.2.02.2.0
http_parser-3.1.43.1.4
intl-0.16.10.16.1
io-0.3.40.3.4
js-0.6.20.6.2
json_annotation-3.1.13.1.1
logging-0.11.40.11.4
matcher-0.12.90.12.9
meta-1.2.41.2.4
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.31.9.3
pedantic-1.9.21.9.2
petitparser-3.1.03.1.0
pool-1.4.01.4.0
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
quiver-2.1.52.1.5
shelf-0.7.90.7.9
shelf_web_socket-0.2.30.2.3
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
stream_channel-2.0.02.0.0
stream_transform-1.2.01.2.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
time-1.3.01.3.0
timing-0.1.1+20.1.1+2
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
web_socket_channel-1.1.01.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs