flutter_contentful 0.2.6
flutter_contentful: ^0.2.6 copied to clipboard

Contentful Delivery API client for Dart. This Dart package is a small abstraction on top of the Contentful Delivery API.

2
likes
80 / 110
pub points
53 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 98 API elements (8.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
equatable^1.2.31.2.62.0.0
http^0.12.20.12.20.13.1
json_annotation^3.0.13.1.14.0.1
meta^1.1.61.3.01.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
http_parser-3.1.44.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.2.3` on equatable does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions equatable to update the constraint.

The constraint `^0.12.2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

2
likes
80
pub points
53%
popularity

Publisher

intive.com

Contentful Delivery API client for Dart. This Dart package is a small abstraction on top of the Contentful Delivery API.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

equatable, http, json_annotation, meta

More

Packages that depend on flutter_contentful