flutter_contentful 0.2.6
flutter_contentful: ^0.2.6 copied to clipboard

Contentful Delivery API client for Dart. This Dart package is a small abstraction on top of the Contentful Delivery API.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add flutter_contentful

With Flutter:

 $ flutter pub pub add flutter_contentful

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  flutter_contentful: ^0.2.6

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:flutter_contentful/client.dart';
import 'package:flutter_contentful/contentful.dart';
import 'package:flutter_contentful/models/asset.dart';
import 'package:flutter_contentful/models/asset.g.dart';
import 'package:flutter_contentful/models/entry.dart';
import 'package:flutter_contentful/models/link.dart';
import 'package:flutter_contentful/models/system_fields.dart';
import 'package:flutter_contentful/models/system_fields.g.dart';
2
likes
80
pub points
53%
popularity

Publisher

intive.com

Contentful Delivery API client for Dart. This Dart package is a small abstraction on top of the Contentful Delivery API.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

equatable, http, json_annotation, meta

More

Packages that depend on flutter_contentful