flume 0.5.0 copy "flume: ^0.5.0" to clipboard
flume: ^0.5.0 copied to clipboard

Implementation of the Flume design system and components for Flutter.

9
likes
120/ 140
pub points
0%
popularity

We analyzed this package 25 hours ago, and awarded it 120 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Documentation URL doesn't exist.

At the time of the analysis https://flume.gameflow.dev was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

OUT: Documenting flume... Discovering libraries... Linking elements... Precaching local docs for 1201649 elements... Initialized dartdoc with 1353 libraries Generating docs for category Foundation from package:flume... Generating docs for category Components from package:flume... Generating docs for category Ambiance from package:flume... Generating docs for library material.dart from package:flume/material.dart... Generating docs for library licenses.dart from package:flume/licenses.dart... [2 more lines] ERR: warning: private API of package:vector_math is reexported by libraries in other packages: from flume.Matrix4.Matrix4: (file:///tmp/analyzerRBSOXQ/pub-cache/hosted/20240227t140000-dot-dartlang-pub.appspot.com/vector_math-2.1.4/lib/src/vector_math_64/matrix4.dart:182:11) referred to by cupertino: (file:///home/worker/flutter/stable/packages/flutter/lib/cupertino.dart:23:9) referred to by flume: (file:///tmp/pana_DPUTSZ/lib/material.dart:3:9) referred to by gestures: (file:///home/worker/flutter/stable/packages/flutter/lib/gestures.dart:8:9) referred to by material: (file:///home/worker/flutter/stable/packages/flutter/lib/material.dart:17:9) referred to by rendering: (file:///home/worker/flutter/stable/packages/flutter/lib/rendering.dart:22:9) referred to by semantics: (file:///home/worker/flutter/stable/packages/flutter/lib/semantics.dart:14:9) referred to by services: (file:///home/worker/flutter/stable/packages/flutter/lib/services.dart:11:9) referred to by widgets: (file:///home/worker/flutter/stable/packages/flutter/lib/widgets.dart:13:9) [306 more lines]

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flume/flume.dart that imports:
  • package:flume/src/ambiance.dart that imports:
  • package:flume/src/ambiance/algorithm/extract.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_object_provider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:flume/flume.dart that imports:
  • package:flume/src/ambiance.dart that imports:
  • package:flume/src/ambiance/algorithm/extract.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_object_provider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:flume/flume.dart that imports:
  • package:flume/src/ambiance.dart that imports:
  • package:flume/src/ambiance/algorithm/extract.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
equatable ^2.0.5 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
flutter_cache_manager ^3.3.1 3.3.1 3.3.1
flutter_staggered_animations ^1.1.1 1.1.1 1.1.1
intl ^0.18.1 0.18.1 0.19.0
provider ^6.0.5 6.1.2 6.1.2
shimmer ^3.0.0 3.0.0 3.0.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
nested - 1.0.0 1.0.0
path - 1.9.0 1.9.0
path_provider - 2.1.2 2.1.2
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
rxdart - 0.27.7 0.27.7
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
sqflite - 2.3.2 2.3.2
sqflite_common - 2.5.3 2.5.3
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 4.3.3 4.3.3
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0
win32 - 5.2.0 5.2.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.18.1` on intl does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.