floor 1.2.0
floor: ^1.2.0 copied to clipboard

The typesafe, reactive, and lightweight SQLite abstraction for your Flutter applications. This library is the runtime dependency.

405
likes
100/ 130
pub points
96%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://floor.codes was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 24 out of 51 API elements (47.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:floor/floor.dart that imports:
  • package:floor/src/sqflite_database_factory.dart that imports:
  • package:sqflite/sqlite_api.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
floor_annotation^1.0.11.0.11.0.1
flutterflutter0.0.00.0.0
meta^1.7.01.7.01.7.0
path^1.8.01.8.01.8.0
sqflite^2.0.0+42.0.0+42.0.0+4
sqflite_common_ffi^2.0.0+32.1.02.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
ffi-1.1.21.1.2
sky_engine-0.0.990.0.99
sqflite_common-2.0.1+12.0.1+1
sqlite3-1.3.11.3.1
synchronized-3.0.03.0.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

405
likes
100
pub points
96%
popularity

Publisher

floor.codes

The typesafe, reactive, and lightweight SQLite abstraction for your Flutter applications. This library is the runtime dependency.

Homepage (missing)

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

floor_annotation, flutter, meta, path, sqflite, sqflite_common_ffi

More

Packages that depend on floor